Sisyphus repository
Last update: 2018-03-19 19:06:56 +0300 | SRPMs: 18261 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 5.1.4-alt1.1
p8: 5.1.4-alt0.M80P.1

Group :: Development/Ruby
Source RPM: activerecord-gems

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (0/0)   Repocop 

Raw spec file

%global gem_name activerecord
%global gem_dir /usr/lib/ruby/gems/%(%ruby_rubyconf RUBY_LIB_VERSION)
%global gem_instdir %gem_dir/gems
%global gem_docdir %gem_dir/doc
%global gem_cache %gem_dir/cache

Name: activerecord-gems
Version: 5.1.4
Release: alt1.1
Summary: ActiveRecord
Group: Development/Ruby
License: MIT,Apache2.0
packager: Denis Medvedev <nbr at>

Source: %name-%version.tar
BuildRequires: ruby  ruby-tools libruby-devel 
BuildRequires: activesupport-gems
BuildArch: noarch
Obsoletes: ruby-activerecord < 5.1.4

ActiveRecord ruby gem

%package doc
Summary: Documentation for %name
Group: Documentation
# SyntaxHighlighter is dual licensed under the MIT and GPL licenses

License: MIT and (MIT or GPL+)
BuildArch: noarch

%description doc
Documentation for %name.

%setup -c -T
tar xvf %SOURCE0
cd %name-%version
#gem install --user builder*.gem

#gem install --user rack*.gem

#gem install --user erubis*.gem

#gem install --user nokogiri*.gem

#gem install --user loo*.gem

#gem install --user thor*.gem

#gem install --user mini_portile*.gem

gem install --user --local activemodel*.gem
gem install --user --local arel*.gem
gem install --user --local active*.gem
#gem install --user --local rails-dom-testing*.gem

#gem install --user rails-html*.gem

#gem install --user railties*.gem

#gem install --user sprockets-3*.gem

#gem install --user *.gem

cd ~/.gem/ruby/%(%ruby_rubyconf RUBY_LIB_VERSION)
tar czvf ~/ar.tgz *

mkdir -p %buildroot/%gem_dir 
cd %buildroot/%gem_dir 
%add_findreq_skiplist /usr/lib/ruby/gems/*

tar xzvf ~/ar.tgz
rm -f gems/thread_safe-0.3.6/examples/bench_cache.rb
# this file has bad shebang 

%exclude %gem_cache
%exclude %gem_docdir

%files doc
%doc %gem_docdir

* Tue Mar 13 2018 Andrey Cherepanov <cas at> 5.1.4-alt1.1
- Rebuild with Ruby 2.5.0

* Fri Dec 29 2017 Denis Medvedev <nbr at> 5.1.4-alt1
- new versions of included gems

* Sun Nov 12 2017 Denis Medvedev <nbr at> 5.0.2-alt2
- Fixed gem dir. Added needed obsoletes.

* Mon Mar 20 2017 Denis Medvedev <nbr at> 5.0.2-alt1
- initial build for ALT Linux Sisyphus. Based on gems.

© 2009–2018 Igor Zubkov