Sisyphus repository
Last update: 2018-03-23 02:07:11 +0300 | SRPMs: 18246 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 2.4.2-alt2
p8: 2.4.1-alt1

Group :: Sciences/Mathematics
Source RPM: octave-database

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (0/0)   Repocop 

Raw spec file

# BEGIN SourceDeps(oneline):
BuildRequires: /usr/bin/octave-config libpq-devel makeinfo texinfo
# END SourceDeps(oneline)

%def_with _octave_arch
%define octave_pkg_version 2.4.2
%define octave_pkg_name database
%define octave_descr_name database
Name: octave-%octave_pkg_name
Version: 2.4.2
Release: alt2
Summary: Database.

Group: Sciences/Mathematics
License: GPLv3+


BuildRequires: octave-devel
%if_with _octave_arch
BuildRequires: gcc-c++ gcc-g77 libfftw3-devel libhdf5-devel liblapack-devel libncurses-devel libreadline-devel
BuildRequires: libGL-devel libGLU-devel libGraphicsMagick-c++-devel libGraphicsMagick-devel fontconfig-devel libfreetype-devel libX11-devel libgl2ps-devel libcurl-devel libsuitesparse-devel libarpack-ng-devel libqrupdate-devel libpcre-devel
BuildArch: noarch
Provides: octave(database) = %version

# octave module BuildRequires: Postgresql (>= 8.3)

BuildRequires: postgresql-devel >= 8.3
# Depends: octave (>= 3.6.2), struct (>= 1.0.12)

Requires: octave >= 3.6.2 octave(struct) >= 1.0.12

Octave-Forge - Extra packages for GNU Octave.
This package contains the %octave_descr_name GNU Octave extension.

Extension Description:
Interface to SQL databases, currently only postgresql using libpq.

%setup -q -n %{octave_pkg_name}-%{octave_pkg_version}

%define build_flags CXXFLAGS=$CXXFLAGS
%build_flags octave -H --no-site-file --eval "pkg build -verbose -nodeps . %SOURCE0"

mkdir -p %buildroot%_datadir/octave/packages
mkdir -p %buildroot%_libdir/octave/packages
octave -H --no-site-file --eval "pkg prefix %buildroot%_datadir/octave/packages %buildroot%_libdir/octave/packages; pkg install -verbose -local -nodeps %octave_pkg_name-%octave_pkg_version-$(octave -H --no-site-file --eval "printf([__octave_config_info__(\"canonical_host_type\"), \"-\",  __octave_config_info__(\"api_version\")])").tar.gz"

%if_with _octave_arch

* Thu May 18 2017 Paul Wolneykien <manowar at> 2.4.2-alt2
- regenerated from template by package builder

* Tue Nov 01 2016 Igor Vlasenko <viy at> 2.4.2-alt1
- regenerated from template by package builder

* Fri Apr 15 2016 Igor Vlasenko <viy at> 2.4.1-alt1
- initial import by package builder

© 2009–2018 Igor Zubkov