Sisyphus repository
Last update: 2018-03-22 22:07:23 +0300 | SRPMs: 18244 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 3.1.1-alt2
p8: 3.0.4-alt1
t7: 2.2.0-alt1.M70T.1
t6: 2.2.0-alt1.M60T.1

Group :: Sciences/Mathematics
Source RPM: octave-parallel

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (0/0)   Repocop 

Raw spec file

# BEGIN SourceDeps(oneline):
BuildRequires: /usr/bin/octave-config makeinfo texinfo
# END SourceDeps(oneline)

%def_with _octave_arch
%define octave_pkg_version 3.1.1
%define octave_pkg_name parallel
%define octave_descr_name parallel
Name: octave-%octave_pkg_name
Version: 3.1.1
Release: alt2
Summary: Parallel Computing.

Group: Sciences/Mathematics
License: GPLv3+


BuildRequires: octave-devel
%if_with _octave_arch
BuildRequires: gcc-c++ gcc-g77 libfftw3-devel libhdf5-devel liblapack-devel libncurses-devel libreadline-devel
BuildRequires: libGL-devel libGLU-devel libGraphicsMagick-c++-devel libGraphicsMagick-devel fontconfig-devel libfreetype-devel libX11-devel libgl2ps-devel libcurl-devel libsuitesparse-devel libarpack-ng-devel libqrupdate-devel libpcre-devel
BuildArch: noarch
Provides: octave(parallel) = %version

# octave module BuildRequires: libgnutls..-dev

BuildRequires: libgnutls-devel
# Depends: octave (>= 3.8.0), struct (>= 1.0.12)

Requires: octave >= 3.8.0 octave(struct) >= 1.0.12

Octave-Forge - Extra packages for GNU Octave.
This package contains the %octave_descr_name GNU Octave extension.

Extension Description:
Parallel execution package. See also package mpi, maintained

%setup -q -n %{octave_pkg_name}-%{octave_pkg_version}

%define build_flags CXXFLAGS=$CXXFLAGS
%build_flags octave -H --no-site-file --eval "pkg build -verbose -nodeps . %SOURCE0"

mkdir -p %buildroot%_datadir/octave/packages
mkdir -p %buildroot%_libdir/octave/packages
octave -H --no-site-file --eval "pkg prefix %buildroot%_datadir/octave/packages %buildroot%_libdir/octave/packages; pkg install -verbose -local -nodeps %octave_pkg_name-%octave_pkg_version-$(octave -H --no-site-file --eval "printf([__octave_config_info__(\"canonical_host_type\"), \"-\",  __octave_config_info__(\"api_version\")])").tar.gz"

%if_with _octave_arch

* Thu May 18 2017 Paul Wolneykien <manowar at> 3.1.1-alt2
- regenerated from template by package builder

* Tue Nov 01 2016 Igor Vlasenko <viy at> 3.1.1-alt1
- regenerated from template by package builder

* Tue Sep 27 2016 Igor Vlasenko <viy at> 3.1.0-alt1
- regenerated from template by package builder

* Wed Apr 13 2016 Igor Vlasenko <viy at> 3.0.4-alt1
- regenerated from template by package builder

* Tue Jul 07 2015 Paul Wolneykien <manowar at> 2.2.0-alt2
- Rebuild with the next version of Octave: 4.0.0

* Thu Jun 18 2015 Gleb F-Malinovskiy <glebfm at> 2.2.0-alt1.1
- Rebuilt for gcc5 C++11 ABI.

* Wed Jul 02 2014 Paul Wolneykien <manowar at> 2.2.0-alt1
- updated by octave-package-builder

* Tue Jan 14 2014 Paul Wolneykien <manowar at> 2.1.1-alt1
- updated by octave-package-builder

© 2009–2018 Igor Zubkov