Sisyphus repository
Last update: 2018-03-21 12:07:06 +0300 | SRPMs: 18245 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 0.07-alt2.1
p8: 0.07-alt2.1
p7: 0.07-alt2.1
t7: 0.07-alt2.1
Platform6: 0.07-alt2.1
t6: 0.07-alt2.1
Platform5: 0.07-alt2
5.1: 0.07-alt2

Other repositories
hide window
CPAN: 0.07

Group :: Development/Perl
Source RPM: perl-Encode-compat

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (0/0)   Repocop 

Current version: 0.07-alt2.1
Built: over 7 years ago
Size: 12.9 KB
Repocop status: ok

Home page:

License: Artistic
Summary: Encode-compat - compatibility layer

WARNING: THIS IS A PROOF-OF-CONCEPT. Most functions are incomplete.
All implementation details are subject to change!

This module provide a compatibility layer for users on perl
versions earlier than v5.7.1. It translates whatever call it receives
into Text::Iconv, or (in the future) Unicode::MapUTF8 to perform
the actual work.

The "is_utf8()", "_utf8_on()" and "_utf8_off()" calls are performed
by the method native to the perl version -- 5.6.1 would use
"pack"/"unpack", 5.6.0 uses "tr//CU", etc.

Theoretically, it could be backported to 5.005 and earlier, with none of
the unicode-related semantics available, and serves only as a
abstraction layer above "Text::Iconv", "Unicode::MapUTF8" and possibly
other transcoding modules.

Current maintainer: Vitaly Lipatov

List of contributors: ACL: List of rpms provided by this srpm:
  • perl-Encode-compat
Recent changes (last three changelog entries):

2010-11-22 Igor Vlasenko <viy at> 0.07-alt2.1

    - repair after perl 5.12 upgrade using girar-nmu

2008-09-06 Vitaly Lipatov <lav at> 0.07-alt2

    - fix directory ownership violation

2005-06-07 Vitaly Lipatov <lav at> 0.07-alt1

    - first build for ALT Linux Sisyphus

© 2009–2018 Igor Zubkov