Sisyphus repository
Last update: 2017-12-18 06:05:53 +0300 | SRPMs: 18242 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 0.00005-alt1
p8: 0.00005-alt1
p7: 0.00004-alt1.1.1
t7: 0.00004-alt1.1.1
Platform6: 0.00004-alt1.1.1
t6: 0.00004-alt1.1.1
Platform5: 0.00004-alt1.1
5.1: 0.00004-alt1.1

Group :: Development/Perl
Source RPM: perl-Event-Notify

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (0/0)   Repocop 

Raw spec file

%define _unpackaged_files_terminate_build 1
BuildRequires: perl(Module/Build.pm)
#

#   - Event-Notify -

#   This spec file was automatically generated by cpan2rpm [ver: 2.027]

#   (ALT Linux revision)

#   The following arguments were used:

#       Event::Notify

#   For more information on cpan2rpm please visit: http://perl.arix.com/

#


%define module Event-Notify
%define m_distro Event-Notify
%define m_name Event-Notify
%define m_author_id DMAKI
%define _enable_test 1

Name: perl-Event-Notify
Version: 0.00005
Release: alt1

Summary: Simple Observer/Notifier

License: Artistic
Group: Development/Perl
Url: http://search.cpan.org/dist/Event-Notify/

BuildArch: noarch
Source: http://www.cpan.org/authors/id/D/DM/DMAKI/Event-Notify-%{version}.tar.gz

# Automatically added by buildreq on Sat Jul 12 2008

BuildRequires: perl-Module-Install perl-Test-MockObject

%description
Event::Notify implements a simple Observer pattern. It's not really
intended to be subclassed, or a fancy system. It just registers observers,
and broadcasts events, that's it. The simplicity is that it can be embedded
in a class that doesn't necessarily want to be a subclass of a notifier.

%prep
%setup -q -n %m_distro-%version

%build
%perl_vendor_build

%install
%perl_vendor_install

%files
%perl_vendor_privlib/*
%doc Changes
%exclude %perl_vendor_archlib

%changelog
* Thu Mar 06 2014 Igor Vlasenko <viy at altlinux.ru> 0.00005-alt1
- automated CPAN update

* Fri Oct 04 2013 Igor Vlasenko <viy at altlinux.ru> 0.00004-alt2
- fixed build

* Mon Nov 22 2010 Igor Vlasenko <viy at altlinux.ru> 0.00004-alt1.1.1
- repair after perl 5.12 upgrade using girar-nmu

* Mon Oct 06 2008 Igor Vlasenko <viy at altlinux.ru> 0.00004-alt1.1
- NMU for unknown reason:
  the person above was too neglectant to add --changelog "- NMU: <reason>" option.

* Sat Jul 12 2008 Michael Bochkaryov <misha at altlinux.ru> 0.00004-alt1
- first build for ALT Linux Sisyphus

 
© 2009–2017 Igor Zubkov