Sisyphus repository
Last update: 2018-03-21 03:07:22 +0300 | SRPMs: 18256 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 1:0.18-alt1
p8: 1:0.18-alt1
p7: 0.1602-alt1
t7: 0.1602-alt1
Platform6: 0.15-alt1
t6: 0.15-alt1

Group :: Development/Perl
Source RPM: perl-ExtUtils-XSpp

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (0/0)   Repocop 

Raw spec file

%define _unpackaged_files_terminate_build 1

#   - ExtUtils::XSpp -

#   This spec file was automatically generated by cpan2rpm [ver: 2.027]

#   (ALT Linux revision)

#   The following arguments were used:

#       --version 0.07 SOURCES/ExtUtils-XSpp-0.07.tar.gz

#   For more information on cpan2rpm please visit:


%define module ExtUtils-XSpp
%define m_distro ExtUtils-XSpp
%define m_name ExtUtils::XSpp
%define m_author_id unknown
%define _enable_test 1

Name: perl-ExtUtils-XSpp
Version: 0.18
Release: alt1
Serial:  1

Summary: ExtUtils-XSpp - Perl module

License: Artistic
Group: Development/Perl

Packager: Slava Dubrovskiy <dubrsl at>
BuildArch: noarch

Patch: perl-ExtUtils-XSpp-fix_build.patch

# Automatically added by buildreq on Sat Jan 30 2010

BuildRequires: perl-Module-Build perl-PerlIO perl-Test-Base perl-Test-Differences

# automatically added during perl 5.8 -> 5.12 upgrade.

# perl-podlators is required for pod2man conversion.

BuildRequires: perl-podlators

XS++ is just a thin layer over plain XS, hence to use it you are
supposed to know, at the very least, C++ and XS.

This means that you will need typemaps for both the normal XS
pre-processor *xsubpp* and the XS++ pre-processor *xspp*.

%setup -q -n %m_distro-%version
%patch -p0

%perl_vendor_build --install_path bindoc=%_man1dir



* Mon Sep 23 2013 Igor Vlasenko <viy at> 1:0.18-alt1
- automated CPAN update

* Wed Jul 24 2013 Igor Vlasenko <viy at> 0.1700-alt1
- automated CPAN update

* Mon Sep 19 2011 Igor Vlasenko <viy at> 0.1602-alt1
- automated CPAN update

* Sat Nov 27 2010 Slava Dubrovskiy <dubrsl at> 0.15-alt1
- 0.15

* Mon Nov 22 2010 Igor Vlasenko <viy at> 0.12-alt1.1
- repair after perl 5.12 upgrade using girar-nmu

* Wed Jul 21 2010 Slava Dubrovskiy <dubrsl at> 0.12-alt1
- 0.12

* Sat Jan 30 2010 Slava Dubrovskiy <dubrsl at> 0.07-alt1
- initial build for ALT Linux Sisyphus

© 2009–2018 Igor Zubkov