Sisyphus repository
Last update: 2018-06-21 14:06:37 +0400 | SRPMs: 18578 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 0.13-alt1
p8: 0.12-alt1
p7: 0.11-alt1.1
t7: 0.11-alt1.1
Platform6: 0.11-alt1.1
t6: 0.11-alt1.1
Platform5: 0.05-alt3
5.1: 0.05-alt3

Other repositories
hide window
CPAN: 0.13

Group :: Development/Perl
Source RPM: perl-MRO-Compat

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (0/1)   Repocop 

Current version: 0.13-alt1
Built: about 1 year ago
Size: 13.3 KB
Repocop status: ok

Home page:   http://search.cpan.org/dist/MRO-Compat

License: GPL
Summary: mro::* interface compatibility for Perls < 5.9.5
Description:

The "mro" namespace provides several utilities for dealing with method
resolution order and method caching in general in Perl 5.9.5 and higher.

This module provides those interfaces for earlier versions of Perl (back to
5.6.0 anyways).

It is a harmless no-op to use this module on 5.9.5+. If you're writing a piece
of software that would like to use the parts of 5.9.5+'s mro:: interfaces that
are supported here, and you want compatibility with older Perls, this is the
module for you.

Some parts of this interface will work better with Class::C3::XS installed, but
it's not a requirement.

This module never exports any functions. All calls must be fully qualified with
the mro:: prefix.

The interface documentation here serves only as a quick reference of what the
function basically does, and what differences between MRO::Compat and 5.9.5+
one should look out for. The main docs in 5.9.5's mro are the real interface
docs, and contain a lot of other

Current maintainer: Igor Vlasenko

List of contributors: ACL: List of rpms provided by this srpm:
  • perl-MRO-Compat
Recent changes (last three changelog entries):

2017-04-03 Igor Vlasenko <viy at altlinux.ru> 0.13-alt1

    - automated CPAN update

2013-10-07 Igor Vlasenko <viy at altlinux.ru> 0.12-alt1

    - automated CPAN update

2010-11-29 Igor Vlasenko <viy at altlinux.ru> 0.11-alt1.1

    - repair after perl 5.12 upgrade using girar-nmu

 
© 2009–2018 Igor Zubkov