Sisyphus repository
Last update: 2017-10-17 09:05:58 +0400 | SRPMs: 17927 | Sign in or Sign up
en ru uk br
ALT Linux repositories
hide window
Sisyphus: 2.4.2-alt2
p8: 2.4.2-alt1.M80P.1
p7: 1.9.3-alt44.M70P.1
t7: 1.9.3-alt44.M70P.1
Platform6: 1.9.2-alt2.r31204.1
t6: 1.9.2-alt2.r31204.1
Platform5: 1.9.1-alt1.r26040.1
5.1: 1.9.1-alt1.r26040.1

Group :: Development/Ruby
Source RPM: ruby

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR (1/26)   Repocop 

Current version: 2.4.2-alt2
Built: 5 days ago
Size: 7.58 MB
Repocop status: ok

Home page:   http://www.ruby-lang.org/

License: BSD (revised) or Ruby
Summary: An Interpreted Object-Oriented Scripting Language
Description:

Ruby is an interpreted scripting language for quick and easy object-oriented
programming. It has many features for processing text files and performing system
management tasks (as in Perl). It is simple, straight-forward, and extensible.

This package contains interpreter of object-oriented scripting language Ruby.

Current maintainer: Ruby Team

List of contributors: ACL: List of rpms provided by this srpm:
  • irb
  • libruby
  • libruby-debuginfo
  • libruby-devel
  • libruby-devel-static
  • ri
  • ruby
  • ruby-debuginfo
  • ruby-doc-ri
  • ruby-stdlibs
  • ruby-stdlibs-debuginfo
  • ruby-tools
Recent changes (last three changelog entries):

2017-10-12 Andrey Cherepanov <cas at altlinux.org> 2.4.2-alt2

    - Merge rubygems-2.6.14 changes
    - Fixes:
    + CVE-2017-0903 Unsafe Object Deserialization Vulnerability in RubyGems

2017-09-16 Andrey Cherepanov <cas at altlinux.org> 2.4.2-alt1

    - New version 2.4.2
    - Security fixes:
    + CVE-2017-0898: Buffer underrun vulnerability in Kernel.sprintf
    + CVE-2017-10784: Escape sequence injection vulnerability in the Basic authentication of WEBrick
    + CVE-2017-14033: Buffer underrun vulnerability in OpenSSL ASN1 decode
    + CVE-2017-14064: Heap exposure in generating JSON

2017-09-05 Andrey Cherepanov <cas at altlinux.org> 2.4.1-alt1

    - New version 2.4.1 with gems 2.6.13
    - Security fixes:
    + CVE-2017-0902 a DNS request hijacking vulnerability
    + CVE-2017-0899 an ANSI escape sequence vulnerability
    + CVE-2017-0900 a DoS vulnerability in the query command
    + CVE-2017-0901 a vulnerability in the gem installer that allowed a malicious gem to overwrite arbitrary files
    - ext/tk: Tk is removed from stdlib. [Feature #8539]

 
© 2009–2017 Igor Zubkov