Package hypre: Information

Source package: hypre
Version: 2.20.0-alt1.1
Build time:  May 30, 2021, 05:13 PM in the task #269879
Report package bug
License: LGPLv2.1
Summary: Scalable algorithms for solving linear systems of equations
Description: 
The goal of the Scalable Linear Solvers project is to develop scalable
algorithms and software for solving large, sparse linear systems of equations on
parallel computers. The primary software product is Hypre, a library of high
performance preconditioners that features parallel multigrid methods for both
structured and unstructured grid problems. The problems of interest arise in the
simulation codes being developed at LLNL and elsewhere to study physical
phenomena in the defense, environmental, energy, and biological sciences.

List of rpms provided by this srpm:
libhypre (x86_64, ppc64le, i586, armh, aarch64)
libhypre-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
libhypre-devel (x86_64, ppc64le, i586, armh, aarch64)

Maintainer: Arseny Maslennikov


    1. libnumpy-devel
    2. java-devel-default
    3. gcc-c++
    4. gcc-fortran
    5. netpbm
    6. /proc
    7. babel
    8. libsuperlu-devel
    9. rpm-build-java
    10. rpm-macros-cmake
    11. cmake
    12. texlive-base-bin
    13. ghostscript-classic
    14. openmpi-devel
    15. liblapack-devel
    16. libltdl-devel
    17. libxml2-devel
    18. emacs-nox

Last changed


April 27, 2021 Arseny Maslennikov 2.20.0-alt1.1
- NMU: spec: adapted to new cmake macros.
Nov. 5, 2020 Vitaly Lipatov 2.20.0-alt1
- new version (2.20.0) with rpmgs script
- cleanup spec, build from tarball, don't pack empty hypre package
- temp. disable docs packing (needs checking)
Nov. 4, 2020 Vitaly Lipatov 2.15.1-alt3
- NMU: update github repo url and add upstream/remotes
- NMU: fix license name, fix the package obsoletes itself error