Package rpminstall-tests

Source package: rpminstall-tests
Version: 1.1.3-alt0.M70T.4
Build time:  Jun 28, 2019, 06:20 PM
 in the task #233385
Category: Development/Tools
Report package bug
License:  GPLv2+
Summary:  Tests for rpm: how it interprets packages when installing
Description: 
Tests for rpm: how it interprets packages when installing.

Now, it tests how various forms of constraints (Requires, Conflicts, Obsoletes)
are interpreted when they are installed together with packages with
various forms of matching Provides.

More tests can appear.
List of rpms provided by this srpm: 
rpminstall-tests (noarch)
rpminstall-tests-checkinstall (noarch)
Maintainer: Ivan Zakharyaschev
List of contributors: 
Ivan Zakharyaschev
    1. rpm-build-licenses
Last changes:
March 14, 2019 Ivan Zakharyaschev 1.1.3-alt0.M70T.4
- Don't skip tests that need rpmbuild that produces Provides: N = E:V-R:D.
  (So all cases are tested now.)
- The reasons of the currently XFAILing tests (with 4.0.4-alt100.77.M70P.4.M70C.1) are
  the same as below for 1.1.3-alt0.M70T.3 (with 4.0.4-alt100.77.M70P.3.M70C.2).
March 13, 2019 Ivan Zakharyaschev 1.1.3-alt0.M70T.3
- New tests for disttag comparison with the obsolete (.) and current format (+)
  (Correct comparison would rely on a fix or a new feature in rpm:
  %_priority_distbranch.)
- New tests for the %_priority_distbranch feature in normal situation.
- The reasons of the currently XFAILing tests (with 4.0.4-alt100.77.M70P.3.M70C.2):
  1. upgrade w.r.t. disttag fails in non-standard configuration without honor_buildtime;
  2. mishandled elusive dep with a release but no epoch.
- Tests are skipped that:
  1. require rpmbuild to generate Provides with :DISTTAG postfix.
March 4, 2019 Ivan Zakharyaschev 1.1.2-alt0.M80P.3
- Unmarked XFAIL: non-critical unrealistic obsoleting a specific disttag.

Back to Top