Package swftools: Information

Source package: swftools
Version: 0.9.2-alt1
Build time:  Apr 22, 2012, 07:38 PM
Category: Graphics
Report package bug
License: GPL
Summary: A collection of SWF manipulation and generation utilities
Description: 
SWF Tools is a collection of SWF manipulation and generation utilities

Included are:

 PDF2SWF A PDF to SWF Converter. Generates one frame per page. Enables
 you to have fully formatted text, including tables, formulas etc.
 inside your Flash Movie. Uses the xpdf PDF parser from Derek B.
 Noonburg and the tt2pt1 font converter developed by the TTF2PT1 Project
 and its contributors.

 SWFCombine A tool for inserting SWFs into Wrapper SWFs. (Templates)
 E.g. for including the pdf2swf SWFs in some sort of Browsing-SWF.

 SWFStrings Scans SWFs for text data.

 SWFDump Prints out various informations about SWFs.

 JPEG2SWF Takes one or more JPEG pictures and generates a SWF slideshow.

 PNG2SWF Like JPEG2SWF, only for PNGs.

 WAV2SWF Converts WAV audio files to SWFs with MP3 Streams, using the
 L.A.M.E. MP3 encoder.

 AVI2SWF Converts AVI animation files to SWF. Still Alpha, but some
 examples can already be found at http://www.swftools.org/examples.html.

 SWFExtract Allows to extract Movieclips, Sounds, Images etc. from SWF
 files.

 RFXSWF Library A fully featured library which can be used for
 standalone SWF generation. Includes support for Bitmaps, Buttons,
 Shapes, Text, Fonts, Sound etc.

 SWFTools has been reported to work on Solaris, Linux, FreeBSD and OSX.

List of rpms provided by this srpm:
swftools (x86_64, i586)
swftools-debuginfo (x86_64, i586)

Maintainer: Michael Shigorin


    1. libgif-devel
    2. gcc-c++
    3. libjpeg-devel
    4. liblame-devel
    5. zlib-devel
    6. libfreetype-devel

Last changed


April 22, 2012 Michael Shigorin 0.9.2-alt1
- 0.9.2
- dropped a patch
- applied gentoo patches
April 21, 2011 Eugeny A. Rostovtsev 0.9.0-alt1.1
- Fixed build
July 29, 2009 Michael Shigorin 0.9.0-alt1
- 0.9.0 (closes: #20860)
  + fixed build with gcc-4.4
- buildreq
- dropped ancient unused patch from the package
- NB: I don't use this package, it needs proper maintainer