Package gcc4.7: Information

Source package: gcc4.7
Version: 4.7.2-alt13
Build time:  Oct 7, 2019, 03:15 PM in the task #238674
Category: Development/C
Report package bug
License: GPLv3+, GPLv3+ with exceptions and GPLv2+ with exceptions
Summary: GNU Compiler Collection
Description: 
This package contains the GNU Compiler Collection version 4.7.2.
You'll need this package in order to compile C code.
It is also required for all other GCC compilers.

If you have multiple versions of the GNU Compiler Collection
installed on your system, you may want to execute
gcc-4.7
in order to explicitly use the GNU C compiler version 4.7.2.

List of rpms provided by this srpm:
cpp4.7 (x86_64, i586)
cpp4.7-debuginfo (x86_64, i586)
gcc4.7 (x86_64, i586)
gcc4.7-c++ (x86_64, i586)
gcc4.7-c++-debuginfo (x86_64, i586)
gcc4.7-debuginfo (x86_64, i586)
gcc4.7-doc (noarch)
gcc4.7-fortran (x86_64, i586)
gcc4.7-fortran-debuginfo (x86_64, i586)
gcc4.7-go (x86_64, i586)
gcc4.7-go-debuginfo (x86_64, i586)
gcc4.7-locales (x86_64, i586)
gcc4.7-objc (x86_64, i586)
gcc4.7-objc++ (x86_64, i586)
gcc4.7-objc++-debuginfo (x86_64, i586)
gcc4.7-objc-debuginfo (x86_64, i586)
gcc4.7-plugin-devel (x86_64, i586)
libgcov4.7-devel (x86_64, i586)
libgfortran4.7-devel (x86_64, i586)
libgfortran4.7-devel-static (x86_64, i586)
libgo0 (x86_64, i586)
libgo0-debuginfo (x86_64, i586)
libgo4.7-devel (x86_64, i586)
libgo4.7-devel-static (x86_64, i586)
libgomp4.7-devel (x86_64, i586)
libgomp4.7-devel-static (x86_64, i586)
libmudflap4.7-devel (x86_64, i586)
libmudflap4.7-devel-static (x86_64, i586)
libobjc4.7-devel (x86_64, i586)
libobjc4.7-devel-static (x86_64, i586)
libquadmath4.7-devel (x86_64, i586)
libquadmath4.7-devel-static (x86_64, i586)
libstdc++4.7-devel (x86_64, i586)
libstdc++4.7-devel-static (x86_64, i586)



    1. makeinfo
    2. perl-Pod-Parser
    3. automake_1.11
    4. binutils >= 1:2.18
    5. coreutils
    6. libelf-devel
    7. rpm-build >= 4.0.4-alt39
    8. libtool_2.4
    9. zlib-devel
    10. libmpc-devel
    11. libmpfr-devel
    12. flex

Last changed


Oct. 4, 2019 Gleb Fotengauer-Malinovskiy 4.7.2-alt13
- Fixed build with libtool 2.4.6 (ldv@).
- gcc4.7-locales: removed noarch.
Feb. 19, 2018 Dmitry V. Levin 4.7.2-alt12
- gcc4.7-fortran: do not obsolete gcc-g77.
Jan. 11, 2018 Gleb Fotengauer-Malinovskiy 4.7.2-alt11
- Fixed build with glibc 2.26, gcc >= 6, and texinfo 6.5.
- Disabled java support.
- Dropped alternatives.