Package hplip: Information

    Source package: hplip
    Version: 3.23.12-alt1
    Build time:  Dec 14, 2023, 06:52 PM in the task #335663
    Category: Publishing
    Report package bug
    License: GPL-2.0+ and MIT and BSD-3-Clause
    Summary: Solution for printing, scanning, and faxing with Hewlett-Packard inkjet and laser printers.
    Description: 
    This is the HP driver package to supply Linux support for most
    Hewlett-Packard DeskJet, LaserJet, PSC, OfficeJet, and PhotoSmart
    printers and all-in-one peripherals (also known as Multi-Function
    Peripherals or MFPs), which can print, scan, copy, fax, and/or access
    flash memory cards.
    
    This package contains various tools for memory card access,
    ink/toner/battery/consumable level checking, and inkjet printer
    maintenance, along with python cups backends.

    List of rpms provided by this srpm:
    hplip (x86_64, ppc64le, i586, armh, aarch64)
    hplip-common (x86_64, ppc64le, i586, armh, aarch64)
    hplip-common-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-gui (noarch)
    hplip-gui-autostart (noarch)
    hplip-hpcups (x86_64, ppc64le, i586, armh, aarch64)
    hplip-hpcups-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-hpijs (x86_64, ppc64le, i586, armh, aarch64)
    hplip-hpijs-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-recommends (noarch)
    hplip-sane (x86_64, ppc64le, i586, armh, aarch64)
    hplip-sane-debuginfo (x86_64, ppc64le, i586, armh, aarch64)

    Maintainer: Andrey Cherepanov


      1. cups-common
      2. cups-filters >= 1.0.46-alt1
      3. libpolkit-devel
      4. python3-devel
      5. python3-module-PyQt5-devel
      6. libcups-devel
      7. libdbus-devel
      8. gcc-c++
      9. perl
      10. libsane-devel
      11. libssl-devel
      12. libstdc++-devel
      13. libavahi-devel
      14. rpm-build-python3
      15. polkit
      16. libjpeg-devel
      17. libnet-snmp-devel
      18. libusb-compat-devel
      19. libusb-devel
      20. zlib-devel

    Last changed


    Dec. 2, 2023 Andrey Cherepanov 1:3.23.12-alt1
    - New version.
    - Added support for the following new printers:
      + HP OfficeJet Pro 9130b, 9120b, 9110b series
      + HP Color LaserJet Enterprise Flow MFP X58045z, X58045zs
      + HP Color LaserJet Enterprise MFP X58045, X58045dn
      + HP LaserJet Pro P1106 plus
      + HP LaserJet Pro P1108 plus
    Sept. 20, 2023 Andrey Cherepanov 1:3.23.8-alt1
    - New version.
    - Added support for the following new printers:
      + HP Color LaserJet Pro MFP 4201, 4202, 4203, 4301, 4302, 4303
      + HP DeskJet 2800 All-in-One Printer series
      + HP DeskJet 2800e All-in-One Printer series
      + HP DeskJet Ink Advantage 2800 All-in-One Printer series
      + HP DeskJet 4200 All-in-One Printer series
      + HP DeskJet 4200e All-in-One Printer series
      + HP DeskJet Ink Advantage 4200 All-in-One Printer series
      + HP DeskJet Ink Advantage Ultra 4900 All-in-One Printer series
    Aug. 12, 2023 Daniel Zagaynov 1:3.23.5-alt2.1
    - NMU:
        + added shebang to python3-modules from %_datadir/%name and made them
          executable to make them visible for python3.req.py
        + ignore self-provide *.sixext.moves