Package mono: Information

Source package: mono
Version: 5.20.1.19-alt8.p9.1
Build time:  Apr 28, 2022, 01:32 AM
Report package bug
License: MIT
Summary: Cross-platform, Open Source, .NET development framework
Description: 
The Mono runtime implements a JIT engine for the ECMA CLI
virtual machine (as well as a byte code interpreter, the
class loader, the garbage collector, threading system and
metadata access libraries.

List of rpms provided by this srpm:
mono-core (x86_64, ppc64le, i586, armh, aarch64)
mono-core-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
mono-data (x86_64, ppc64le, i586, armh, aarch64)
mono-data-oracle (x86_64, ppc64le, i586, armh, aarch64)
mono-data-sqlite (x86_64, ppc64le, i586, armh, aarch64)
mono-devel (x86_64, ppc64le, i586, armh, aarch64)
mono-devel-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
mono-devel-full (x86_64, ppc64le, i586, armh, aarch64)
mono-dyndata (x86_64, ppc64le, i586, armh, aarch64)
mono-extras (x86_64, ppc64le, i586, armh, aarch64)
mono-full (x86_64, ppc64le, i586, armh, aarch64)
mono-locale-extras (x86_64, ppc64le, i586, armh, aarch64)
mono-mono2-compat (x86_64, ppc64le, i586, armh, aarch64)
mono-mono2-compat-devel (x86_64, ppc64le, i586, armh, aarch64)
mono-monodoc (x86_64, ppc64le, i586, armh, aarch64)
mono-monodoc-devel (x86_64, ppc64le, i586, armh, aarch64)
mono-mvc (x86_64, ppc64le, i586, armh, aarch64)
mono-mvc-devel (x86_64, ppc64le, i586, armh, aarch64)
mono-nunit (x86_64, ppc64le, i586, armh, aarch64)
mono-reactive (x86_64, ppc64le, i586, armh, aarch64)
mono-reactive-devel (x86_64, ppc64le, i586, armh, aarch64)
mono-reactive-winforms (x86_64, ppc64le, i586, armh, aarch64)
mono-wcf (x86_64, ppc64le, i586, armh, aarch64)
mono-web (x86_64, ppc64le, i586, armh, aarch64)
mono-web-devel (x86_64, ppc64le, i586, armh, aarch64)
mono-winforms (x86_64, ppc64le, i586, armh, aarch64)
mono-winfx (x86_64, ppc64le, i586, armh, aarch64)

Maintainer: Andrey Cherepanov


    1. python3
    2. perl-Pod-Usage
    3. gcc-c++
    4. pkg-config
    5. /proc
    6. rpm-build-mono >= 2.0
    7. gettext-devel
    8. rpm-build-ubt
    9. cmake
    10. valgrind-devel
    11. libgdiplus-devel >= 2.10
    12. zlib-devel

Last changed


Nov. 2, 2021 Andrey Cherepanov 5.20.1.19-alt8.p9.1
- Ignore possible fail of %post core scriptlet.
Nov. 18, 2020 Aleksei Nikiforov 5.20.1.19-alt8
- Repackaged some libraries (Closes: #39254).
Nov. 11, 2020 Vitaly Lipatov 5.20.1.19-alt7
- move mono-test-install to mono-devel package (it uses pkg-config file from it)
- use python3 during build, don't require python2-base in mono-core