Package babel

Source package: babel
Version: 2.0.0-alt5
Build time:  Sep 3, 2021, 04:46 PM
Category: Sciences/Mathematics
Report package bug
License:  LGPLv2.1
Summary:  Language tool for high-performance scientific computing community
Description: 
  Babel is a language interoperability tool intended for use by
the high-performance scientific computing community.  Developed
by the Components project (http://www.llnl.gov/CASC/components)
at Lawrence Livermore National Laboratory, Babel supports the
Scientific Interface Definition Language (SIDL) for the language-
independent declaration of interfaces associated with scientific
software packages.

  The Babel tool, applied to a SIDL file, results in the automatic
generation of the associated skeleton and stub source files.  The
Babel user then need only add the necessary code to the _Impl source
files to complete the provision of a language-independent interface
to the package described by the SIDL file.  The languages currently
supported by Babel are C, C++, F77, F90, Java and Python.

This package contains main compiler files. Conflicts with Open Babel, because
contains another file named 'babel' in /usr/bin.
List of rpms provided by this srpm: 
babel (e2kv5, e2kv4, e2k)
babel-common (noarch)
babel-j (noarch)
babel-javadoc (noarch)
babel-manual (noarch)
libbabel (e2kv5, e2kv4, e2k)
libbabel-debuginfo (e2kv5, e2kv4, e2k)
libbabel-devel (e2kv5, e2kv4, e2k)
Last changes:
Sept. 2, 2021 Michael Shigorin 2.0.0-alt5
- E2K: avoid lcc-unsupported option (and fortran altogether)
- minor spec cleanup
Aug. 17, 2021 Vitaly Lipatov 2.0.0-alt4
- disable BR: libnumpy-devel when build without python
Aug. 14, 2021 Igor Vlasenko 2.0.0-alt3.1
- NMU: java BR: cleanup

Back to Top