Package lcc1.25: Information

Source package: lcc1.25
Version: 1.25.17-alt3
Build time:  Jun 30, 2021, 05:05 AM
Category: Development/C
Report package bug
License: non-free
Summary: Elbrus C compiler (for e2k)
Description: 
This package contains the lcc C compiler (for e2k),
which has been provided by MCST as precompiled binaries
in the form of deb packages.

This version of lcc is claimed to be compatible with GCC 7.

List of rpms provided by this srpm:
lcc1.25 (e2kv5, e2kv4, e2k)
lcc1.25-c++ (e2kv5, e2kv4, e2k)
lcc1.25-c++-debuginfo (e2kv5, e2kv4, e2k)
lcc1.25-cpp (e2kv5, e2kv4, e2k)
lcc1.25-cpp-debuginfo (e2kv5, e2kv4, e2k)
lcc1.25-debuginfo (e2kv5, e2kv4, e2k)
lcc1.25-doc (noarch)
lcc1.25-extra (e2kv5, e2kv4, e2k)
lcc1.25-fortran (e2kv5, e2kv4, e2k)
lcc1.25-fortran-debuginfo (e2kv5, e2kv4, e2k)
lcc1.25-full (noarch)

Maintainer: Andrew Savchenko


    1. lcc-blobs = 1.25.17

Last changed


June 30, 2021 Andrew Savchenko 1.25.17-alt3
- Apply v5 fix backport properly.
June 27, 2021 Andrew Savchenko 1.25.17-alt2
- Backport builtin alginment fix for v5 from 1.25.18.
- Update lcc man to denote default -O3 optlevel.
May 19, 2021 Andrew Savchenko 1.25.17-alt1
- Update to 1.25.17.