Package nss_wrapper: Information

Source package: nss_wrapper
Version: 1.1.11-alt1
Build time:  Jun 23, 2021, 09:24 PM
Report package bug
Home page: https://cwrap.org/

License: BSD
Summary: A wrapper for the user, group and hosts NSS API
Description: 
There are projects which provide daemons needing to be able to create, modify
and delete Unix users. Or just switch user ids to interact with the system e.g.
a user space file server. To be able to test that you need the privilege to
modify the passwd and groups file. With nss_wrapper it is possible to define
your own passwd and groups file which will be used by software to act correctly
while under test.

If you have a client and server under test they normally use functions to
resolve network names to addresses (dns) or vice versa. The nss_wrappers allow
you to create a hosts file to setup name resolution for the addresses you use
with socket_wrapper.

To use it set the following environment variables:

LD_PRELOAD=libuid_wrapper.so
NSS_WRAPPER_PASSWD=/path/to/passwd
NSS_WRAPPER_GROUP=/path/to/group
NSS_WRAPPER_HOSTS=/path/to/host

This package doesn't have a devel package cause this project is for
development/testing.

List of rpms provided by this srpm:
nss_wrapper (e2kv5, e2kv4, e2k)
nss_wrapper-debuginfo (e2kv5, e2kv4, e2k)

Maintainer: Evgeny Sinelnikov


    1. libcmocka-devel
    2. cmake
    3. ctest

Last changed


Feb. 7, 2021 Evgeny Sinelnikov 1.1.11-alt1
- Update to latest release.
Dec. 4, 2018 Evgeny Sinelnikov 1.1.5-alt1
- Update to latest release with compatibility fixes
Aug. 21, 2017 Aleksei Nikiforov 1.1.3-alt1
- Initial build for ALT.