Package ghostscript: Information

Source package: ghostscript
Version: 9.27-alt1.M90P.1
Build time:  Oct 2, 2020, 08:53 PM
Category: Publishing
Report package bug
License: GPLv3+ and Redistributable, no modification permitted
Summary: PostScript interpreter and renderer, most printer drivers
Description: 
Ghostscript is a set of software that provides a PostScript(TM) interpreter,
a set of C procedures (the Ghostscript library, which implements the
graphics capabilities in the PostScript language) and an interpreter for
Portable Document Format (PDF) files. Ghostscript translates PostScript code
into many common, bitmapped formats, like those understood by your printer
or screen. Ghostscript is normally used to display PostScript files and to
print PostScript files to non-PostScript printers.
Most applications use PostScript for printer output.

In addition, the package contains filters which transfer the raw
bitmap of GhostScript into the protocol of some additional printer
models.

You should install ghostscript if you need to display PostScript files, or
if you have a non-PostScript printer.

List of rpms provided by this srpm:
ghostscript (mipsel)
ghostscript-classic (mipsel)
ghostscript-classic-debuginfo (mipsel)
ghostscript-common (noarch)
ghostscript-gtk (mipsel)
ghostscript-gtk-debuginfo (mipsel)
ghostscript-module-X (mipsel)
ghostscript-module-X-debuginfo (mipsel)
ghostscript-utils (noarch)
libgs (mipsel)
libgs-debuginfo (mipsel)
libgs-devel (mipsel)
libijs (mipsel)
libijs-debuginfo (mipsel)
libijs-devel (mipsel)

Maintainer: Aleksei Nikiforov


    1. imake
    2. libopenjpeg2.0-devel
    3. libXt-devel
    4. libgtk+3-devel
    5. libpaper-devel
    6. libpng-devel
    7. libtiff-devel
    8. libjpeg-devel
    9. libcups-devel
    10. ghostscript-utils
    11. glibc-devel-static
    12. xorg-cf-files
    13. docbook-utils-print
    14. libexpat-devel

Last changed


Oct. 1, 2020 Aleksei Nikiforov 9.27-alt1.M90P.1
- Applied security fixes from upstream (Fixes: CVE-2019-10216, CVE-2019-14811,
  CVE-2019-14812, CVE-2019-14813, CVE-2019-14817, CVE-2019-14869).
May 6, 2019 George V. Kouryachy 9.27-alt1
- Autobuild version bump to 9.27
- Update patchset
- Manually hack upstream to build libgpdl.so
April 4, 2019 Ivan Zakharyaschev 9.26-alt3
- (.spec) make Provides and Requires match (on %name-lib = %version)
  (Otherwise, there would be an unmet dep when rebuilt and interpreted
  by rpm-4.13.0.1-alt6 and rpm-build with the corresponding fix.)