Package pam_p11: Information

Source package: pam_p11
Version: 0.2.0-alt1
Build time:  Apr 28, 2019, 03:04 AM
Category: System/Base
Report package bug
License: LGPLv2.1+
Summary: Simple RSA authentication with PKCS#11 modules
Description: 
pam_p11 is a pluggable authentication module (PAM) package for
using cryptographic PKCS#11 tokens such as smart cards and USB
crypto tokens for local authentication.

pam_p11 uses libp11 to access any PKCS#11 module but it is
primarily developed for and tested with OpenSC PKCS#11.

pam_p11 implements two authentication modules:
* pam_p11_openssh authenticates the user against public keys
  found in OpenSSH ~/.ssh/authorized_keys file.
* pam_p11_opensc authenticates the user against certificates
  found in ~/.eid/authorized_certificates_. It is compatible with
  the older opensc "pamopensc" authentication module (eid mode).

pam_p11 is very simple, it has no config file, no options other
than the PKCS#11 module file, does not know about certificate
chains, certificate authorities, revocation lists or OCSP.
Perfect for the small installation with no frills.

pam_p11 was written by an international team and is licensed as
Open Source software under the LGPL license.

List of rpms provided by this srpm:
pam_p11 (mipsel)
pam_p11-debuginfo (mipsel)

Maintainer: Michael Shigorin


    1. libp11-devel
    2. libpam-devel
    3. zlib-devel
    4. libssl-devel

Last changed


Aug. 31, 2018 Alexey Shabalin 0.2.0-alt1
- 0.2.0
- build with openssl-1.1
Sept. 21, 2015 Michael Shigorin 0.1.5-alt4
- built for ALT Linux again (bits based on openSUSE spec)
May 25, 2009 Lebedev Sergey 0.1.5-alt3
- fixed build with new automake-1.11