Package gd2: Information

Danger alert: Package removed from sisyphus repository

Removed in the task: #223028
Package removed: Dmitry V. Levin
Deletion date: March 8, 2019
Message: remove_legacy_library
    Source package: gd2
    Version: 2.0.35-alt7.S1
    Build time:  Apr 27, 2018, 03:29 AM in the task #204597
    Category: Graphics
    Report package bug
    License: BSD-style
    Summary: A graphics library for drawing image files in various formats
    Description: 
    Gd is a graphics library.  It allows your code to quickly draw images
    complete with lines, arcs, text, multiple colors, cut and paste from
    other images, and flood fills, and write out the result as a PNG or
    JPEG file.  This is particularly useful in World Wide Web applications,
    where PNG and JPEG are two of the formats accepted for inline images
    by most browsers.
    
    Gd is not a paint program.  If you are looking for a paint program, you
    are looking in the wrong place.  If you are not a programmer, you are
    looking in the wrong place, unless you are installing a required
    library in order to run an application.
    
    Gd does not provide for every possible desirable graphics operation.
    It is not necessary or desirable for Gd to become a kitchen-sink
    graphics package, but version 2.0 does include most frequently
    requested features, including both truecolor and palette images,
    resampling (smooth resizing of truecolor images) and so forth.

    List of rpms provided by this srpm:
    libgd2 (x86_64, i586)
    libgd2-debuginfo (x86_64, i586)

    Maintainer: Aleksei Nikiforov


      1. libfreetype-devel
      2. libXpm-devel
      3. libpng-devel
      4. rpm-build-ubt
      5. fontconfig-devel
      6. libjpeg-devel

    Last changed


    April 18, 2018 Aleksei Nikiforov 2.0.35-alt7.S1
    - Rebuilt as legacy library.
    April 18, 2013 Vladimir Lettiev 2.0.35-alt6
    - Fixed gdImageFill stack overflow comparison (libGD #177)
    Sept. 27, 2012 Dmitry V. Levin 2.0.35-alt5
    - Check max colors while loading gd palette image (fixes CVE-2009-3546).