Package gem-setup: Information

Source package: gem-setup
Version: 5.999.6-alt5
Build time:  Nov 24, 2022, 12:08 PM
 in the task #310522
Category: Development/Ruby
Report package bug
License: BSD-2-Clause 
Summary:  Ruby's Classic Site Installer
Description: 
Every well practiced Rubyist is aware of Minero Aoki's ever setup.rb script.
It's how most of us used to install our Ruby programs before RubyGems came
along. And it's still mighty useful in certain scenarios, not the least of
which is the job of the distro package maintainer.

Ruby Setup converts setup.rb into a stand-alone application. No longer
requiring the distribution of the setup.rb script with every Ruby package.
Just instruct one's users to install Ruby Setup (gem install setup) and go from
there. As long as a project is setup.rb compliant, as most are, then there is
little to nothing it's developer must do.
List of rpms provided by this srpm: 
gem-setup (noarch)
gem-setup-doc (noarch)
setup-rb (noarch)
Maintainer: Ruby Maintainers Team
List of contributors: 
Pavel Skrylev

ACL: Pavel Skrylev,  @ruby,  @everybody
    1. rpm-build-ruby
Last changes:
Nov. 24, 2022 Pavel Skrylev 5.999.6-alt5
- ! ridir to docdir with ri arg, to support old rubies
Sept. 30, 2022 Pavel Skrylev 5.999.6-alt4
- ! fix hoe loading with version detection
Sept. 21, 2022 Pavel Skrylev 5.999.6-alt3
- ! fix to gem build file placement
Back to Top