Package hplip: Information

    Source package: hplip
    Version: 3.23.12-alt4
    Latest version according to Repology
    Build time:  Mar 11, 2024, 09:03 AM in the task #342430
    Category: Publishing
    Report package bug
    License: GPL-2.0+ and MIT and BSD-3-Clause
    Summary: Solution for printing, scanning, and faxing with Hewlett-Packard inkjet and laser printers.
    Description: 
    This is the HP driver package to supply Linux support for most
    Hewlett-Packard DeskJet, LaserJet, PSC, OfficeJet, and PhotoSmart
    printers and all-in-one peripherals (also known as Multi-Function
    Peripherals or MFPs), which can print, scan, copy, fax, and/or access
    flash memory cards.
    
    This package contains various tools for memory card access,
    ink/toner/battery/consumable level checking, and inkjet printer
    maintenance, along with python cups backends.

    List of rpms provided by this srpm:
    hplip (x86_64, ppc64le, i586, armh, aarch64)
    hplip-common (x86_64, ppc64le, i586, armh, aarch64)
    hplip-common-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-gui (noarch)
    hplip-gui-autostart (noarch)
    hplip-hpcups (x86_64, ppc64le, i586, armh, aarch64)
    hplip-hpcups-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-hpijs (x86_64, ppc64le, i586, armh, aarch64)
    hplip-hpijs-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
    hplip-recommends (noarch)
    hplip-sane (x86_64, ppc64le, i586, armh, aarch64)
    hplip-sane-debuginfo (x86_64, ppc64le, i586, armh, aarch64)

    Maintainer: Andrey Cherepanov



      1. cups-common
      2. cups-filters >= 1.0.46-alt1
      3. libavahi-devel
      4. libcups-devel
      5. libdbus-devel
      6. gcc-c++
      7. libjpeg-devel
      8. libnet-snmp-devel
      9. libpolkit-devel
      10. libsane-devel
      11. libssl-devel
      12. libstdc++-devel
      13. libusb-compat-devel
      14. libusb-devel
      15. perl
      16. polkit
      17. zlib-devel
      18. python3-devel
      19. python3-module-PyQt5-devel
      20. rpm-build-python3

    Last changed


    March 11, 2024 Andrey Cherepanov 1:3.23.12-alt4
    - FTBFS: fixed build.
    March 2, 2024 Andrey Cherepanov 1:3.23.12-alt3
    - Requires python3-module-pygobject3 (ALT #49591).
    Feb. 21, 2024 Andrey Cherepanov 1:3.23.12-alt2
    - Fixed crash on readfp (ALT #49464).