Package kumir: Information

Danger alert: Package removed from sisyphus repository

Removed in the task: #276307
Package removed: Sergey V Turchin
Deletion date: June 29, 2021
Message: obsolete_by_kumir2__and_delete_qt4webkit
Source package: kumir
Version: 1.9.1.2810-alt4
Build time:  Aug 5, 2020, 06:27 PM in the task #255912
Category: Education
Report package bug
License: GPLv2
Summary: Kumir is a simple programming language and IDE for teaching programming
Description: 
Implementation of Kumir programming language, designed by academician
Ershov. It has very simple syntax, also known as "Russian algorithmical
language". Includes compiler, runtime, IDE and  modules "Robot", "Draw",
"Turtle" and some others.

List of rpms provided by this srpm:
kumir (x86_64, ppc64le, i586, aarch64)
kumir-debuginfo (x86_64, ppc64le, i586, aarch64)

Maintainer: Denis Kirienko


    1. libGL-devel
    2. gcc-c++
    3. python-modules
    4. libqt4-webkit-devel

Last changed


July 30, 2020 Pavel Vasenkov 1.9.1.2810-alt4
- NMU: set correct python2 executable in shebang and scripts
  * apply patch for fix maybe-uninitialized variable
Feb. 11, 2019 Pavel Moseev 1.9.1.2810-alt3
- no return statement in the non-void function fixed (according g++8)
Feb. 1, 2019 Michael Shigorin 1.9.1.2810-alt2
- Fixed BR: (needs libqt4-webkit which will pull in the main one)