Package libgtk4: Information

Source package: libgtk4
Version: 4.12.5-alt1
Latest version according to Repology
Build time:  Jan 19, 2024, 06:31 PM in the task #338236
Category: System/Libraries
Report package bug
Home page: http://www.gtk.org

Summary: The GIMP ToolKit (GTK)
Description: 
GTK is a multi-platform toolkit for creating graphical user interfaces.
Offering a complete set of widgets, GTK is suitable for projects
ranging from small one-off projects to complete application suites.

This package contains X11 part of GTK. It is required for GNOME 3 desktop
and programs.

List of rpms provided by this srpm:
gtk4-demo (x86_64, ppc64le, i586, armh, aarch64)
gtk4-demo-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
gtk4-update-icon-cache (x86_64, ppc64le, i586, armh, aarch64)
gtk4-update-icon-cache-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
libgtk4 (x86_64, ppc64le, i586, armh, aarch64)
libgtk4-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
libgtk4-devel (x86_64, ppc64le, i586, armh, aarch64)
libgtk4-devel-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
libgtk4-devel-doc (noarch)
libgtk4-devel-doc-examples (noarch)
libgtk4-gir (x86_64, ppc64le, i586, armh, aarch64)
libgtk4-gir-devel (noarch)

Maintainer: Yuri N. Sedunov

List of contributors:
Yuri N. Sedunov


    1. docbook-utils
    2. fontconfig-devel >= 2.2.1-alt2
    3. gcc-c++
    4. gi-docgen
    5. glib2-devel >= 2.72
    6. gobject-introspection-devel >= 1.72
    7. gtk-update-icon-cache
    8. iso-codes-devel
    9. libEGL-devel
    10. libX11-devel
    11. libXcursor-devel
    12. libXdamage-devel
    13. libXext-devel
    14. libXfixes-devel
    15. libXi-devel
    16. libXinerama-devel
    17. libXrandr-devel
    18. libXrender-devel
    19. libXt-devel
    20. libatk-devel >= 2.15.1
    21. libatk-gir-devel >= 2.15.1
    22. libcairo-devel >= 1.14.0
    23. libcairo-gobject-devel >= 1.14.0
    24. libcanberra-gtk3-devel
    25. libcloudproviders-devel >= 0.2.5
    26. libcolord-devel >= 0.1.9
    27. libcups-devel >= 1.6
    28. libepoxy-devel >= 1.4
    29. libpango-devel >= 1.50.0
    30. libpango-gir-devel
    31. libfribidi-devel
    32. libgdk-pixbuf-devel >= 2.30.0
    33. libgdk-pixbuf-gir-devel
    34. libgio-devel
    35. librsvg-devel >= 2.52.0
    36. libgraphene-devel >= 1.10
    37. libgraphene-gir-devel
    38. libharfbuzz-devel
    39. libjpeg-devel
    40. libtiff-devel
    41. rpm-macros-meson
    42. python3-module-docutils
    43. python3-module-pygobject3
    44. sassc
    45. libwayland-client-devel >= 1.17.0
    46. libwayland-cursor-devel
    47. libwayland-egl-devel
    48. rpm-build-gir
    49. rpm-build-gnome
    50. wayland-protocols >= 1.21
    51. zlib-devel
    52. libxkbcommon-devel >= 0.2.0
    53. meson >= 0.63
    54. pkgconfig(gstreamer-player-1.0)

Last changed


Jan. 18, 2024 Yuri N. Sedunov 4.12.5-alt1
- 4.12.5
Nov. 18, 2023 Yuri N. Sedunov 4.12.4-alt1
- 4.12.4
Sept. 28, 2023 Yuri N. Sedunov 4.12.3-alt1
- 4.12.3