Package lua5.4-luarocks: Information

    Source package: lua5.4-luarocks
    Version: 3.9.2-alt2
    Latest version according to Repology
    Build time:  Jan 23, 2024, 09:07 AM in the task #338345
    Report package bug
    License: MIT
    Summary: A deployment and management system for Lua modules
    Description: 
    LuaRocks allows you to install Lua modules as self-contained
    packages called "rocks", which also contain version dependency
    information. This information is used both during installation,
    so that when one rock is requested all rocks it depends on are
    installed as well, and at run time, so that when a module is
    required, the correct version is loaded. LuaRocks supports both
    local and remote repositories, and multiple local rocks trees.
    
    This is the instance for lua 5.4

    List of rpms provided by this srpm:
    lua5.1-luarocks (x86_64, ppc64le, i586, armh, aarch64)
    lua5.3-luarocks (x86_64, ppc64le, i586, armh, aarch64)
    lua5.4-luarocks (x86_64, ppc64le, i586, armh, aarch64)

    Maintainer: Ildar Mulyukov


    ACL:
    Alexey Shabalin
    @everybody

      1. lua5.1
      2. lua5.3
      3. rpm-build-lua
      4. rpm-macros-lua >= 1.5.2
      5. liblua5.4-devel
      6. wget
      7. unzip

    Last changed


    Jan. 17, 2024 Ildar Mulyukov 3.9.2-alt2
    - get back to the multi-Lua packaging
    April 14, 2023 Alexey Shabalin 3.9.2-alt1
    - Initial build for lua 5.4
    June 15, 2019 Ildar Mulyukov 2.4.2-alt7
    - Also:
    - Fri Jun 23 2023 Ildar Mulyukov <ildar@altlinux.ru> 2.4.2-alt9
    - add Requires: rpm-build-lua
    - built rpms no longer have dependency on luarocks
    - Fri May 12 2023 Alexandr Shashkin <dutyrok@altlinux.org> 2.4.2-alt8
    - luarocks.spec: edit conflicts for lua5.1-luarocks subpackage
    - replace lua-devel by liblua5.3-devel
    - Sat Jun 15 2019 Ildar Mulyukov <ildar@altlinux.ru> 2.4.2-alt7
    - improved luarocks.filetrigger (closes: 36897)