Package php8.3-swoole: Information

Source package: php8.3-swoole
Version: 5.1.2-alt1.3
Latest version according to Repology
Build time:  Feb 21, 2024, 03:58 AM in the task #341111
Category: System/Servers
Report package bug
License: Apache-2.0
Summary: Coroutine-based concurrency library for PHP
Description: 
php-swoole extension provides an event-driven asynchronous and
coroutine-based concurrency networking communication engine
with high performance written in C++ for PHP.

Swoole main features are includes:
- event-driven
- coroutine
- asynchronous non-blocking
- multi-thread reactor
- multi-process worker
- multi-protocol
- millisecond timer
- built-in tcp/http/websocket/http2 server
- coroutine tcp/http/websocket client
- coroutine mysql client
- coroutine redis client
- coroutine read/write file system
- coroutine dns lookup
- support IPv4/IPv6/UnixSocket/TCP/UDP
- support SSL/TLS encrypted transmission

List of rpms provided by this srpm:
php8.3-swoole (x86_64, ppc64le, aarch64)
php8.3-swoole-debuginfo (x86_64, ppc64le, aarch64)

Maintainer: Anton Farygin

List of contributors:
Anton Farygin
Nikolay A. Fetisov

ACL:
Anton Farygin
@everybody

    1. boost-devel-headers
    2. php-devel = 8.3.3
    3. gcc-c++
    4. rpm-build-licenses
    5. rpm-build-php8.3-version
    6. zlib-devel
    7. libbrotli-devel
    8. libcurl-devel
    9. libpcre-devel
    10. libssl-devel

Last changed


Feb. 20, 2024 Anton Farygin 5.1.2-alt1.3
- Rebuild with php-devel = 8.3.3-5.1.2-alt1.3
Feb. 14, 2024 Anton Farygin 5.1.2-alt1
- 5.1.2 (Closes: #49121)
Jan. 19, 2024 Anton Farygin 5.1.1-alt2
- added upstream fix against php 8.3 (Closes: #49116)
- removed postscripts (there is a filetrigger)