Package rpm: Information

    Source package: rpm
    Version: 4.13.0.1-alt40
    Latest version according to Repology
    Build time:  Mar 27, 2024, 06:56 PM in the task #327286
    Report package bug
    License: GPLv2+
    Summary: The RPM package management system
    Description: 
    The RPM Package Manager (RPM) is a powerful command line driven
    package management system capable of installing, uninstalling,
    verifying, querying, and updating software packages. Each software
    package consists of an archive of files along with information about
    the package like its version, a description, etc.

    List of rpms provided by this srpm:
    librpm-devel (x86_64, ppc64le, i586, aarch64)
    librpm-devel-debuginfo (x86_64, ppc64le, i586, aarch64)
    librpm7 (x86_64, ppc64le, i586, aarch64)
    librpm7-debuginfo (x86_64, ppc64le, i586, aarch64)
    librpmbuild7 (x86_64, ppc64le, i586, aarch64)
    librpmbuild7-debuginfo (x86_64, ppc64le, i586, aarch64)
    python-module-rpm (x86_64, ppc64le, i586, aarch64)
    python-module-rpm-debuginfo (x86_64, ppc64le, i586, aarch64)
    python3-module-rpm (x86_64, ppc64le, i586, aarch64)
    python3-module-rpm-debuginfo (x86_64, ppc64le, i586, aarch64)
    rpm (x86_64, ppc64le, i586, aarch64)
    rpm-checkinstall (noarch)
    rpm-debuginfo (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-hdrcache (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-hdrcache-debuginfo (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-ima (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-ima-debuginfo (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-syslog (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-syslog-debuginfo (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-systemd-inhibit (x86_64, ppc64le, i586, aarch64)
    rpm-plugin-systemd-inhibit-debuginfo (x86_64, ppc64le, i586, aarch64)
    rpm2archive (x86_64, ppc64le, i586, aarch64)
    rpm2archive-debuginfo (x86_64, ppc64le, i586, aarch64)
    rpmspec (x86_64, ppc64le, i586, aarch64)
    rpmspec-debuginfo (x86_64, ppc64le, i586, aarch64)

    Maintainer: Alexey Sheplyakov



      1. automake
      2. bzip2-devel
      3. libgcrypt-devel
      4. liblua5.3-devel
      5. liblzma-devel >= 4.999.8
      6. liblzo2-devel
      7. libmagic-devel
      8. elfutils-devel >= 0.112
      9. libmemcached-devel
      10. fakechroot
      11. gawk
      12. libselinux-devel
      13. libsha1detectcoll-devel
      14. gettext-devel
      15. libtool
      16. libzstd-devel
      17. libacl-devel
      18. libarchive-devel
      19. popt-devel >= 1.10.2
      20. python-devel >= 2.6
      21. python-module-setuptools
      22. libcap-devel
      23. libdb4-devel
      24. libdbus-devel
      25. libelf-devel
      26. python3-devel >= 3.2
      27. python3-module-setuptools
      28. readline-devel
      29. rpm-build-python3
      30. strace
      31. zlib-devel

    Last changed


    Oct. 4, 2023 Alexey Sheplyakov 4.13.0.1-alt40
    - Plug a memory leak in python bindings (closes: #47836).
    Sept. 10, 2023 Vitaly Chikunov 4.13.0.1-alt39
    - Add support for caret in version/release to enable in the future. This is
      safe since sisyphus_check will not pass versions like this.
    - Suppress pdeath_execute post-update script open error in RPM::RootDir.
    - pdeath_execute will use pidfd if possible (also added tests).
    July 5, 2023 Andrey Limachko 4.13.0.1-alt38
    - Add support for loongarch64 (thx zhangwenlong)
    - Fix canonical loongarch64 and e2k arch numbers conflict