Package scribus: Information

Source package: scribus
Version: 1.5.8-alt3
Latest version according to Repology
Build time:  Jan 23, 2024, 09:49 AM in the task #338646
Category: Publishing
Report package bug
License: GPLv2+
Summary: Desktop Publishing application written in Qt
Description: 
Scribus is an desktop open source page layout program with
the aim of producing commercial grade output in PDF and
Postscript, primarily, though not exclusively for Linux.

While the goals of the program are for ease of use and simple easy to
understand tools, Scribus offers support for professional publishing
features, such as CMYK color, easy PDF creation, Encapsulated Postscript
import/export and creation of color separations.

List of rpms provided by this srpm:
scribus (x86_64, ppc64le, i586, armh, aarch64)
scribus-data (noarch)
scribus-debuginfo (x86_64, ppc64le, i586, armh, aarch64)
scribus-doc (noarch)

Maintainer: Paul Wolneykien


ACL:
Michael Shigorin
@everybody

    1. GraphicsMagick
    2. boost-devel-headers
    3. cmake
    4. fontconfig-devel >= 2.0
    5. ghostscript > 9.0
    6. libGraphicsMagick-c++-devel
    7. libcairo-devel >= 1.14.0
    8. libcdr-devel
    9. libcups-devel
    10. libfreehand-devel
    11. libfreetype-devel >= 2.1.7
    12. libharfbuzz-devel >= 0.9.42
    13. libhunspell-devel
    14. libicu-devel
    15. libjpeg-devel
    16. liblcms2-devel >= 2.1
    17. libmspub-devel
    18. libpagemaker-devel
    19. libpodofo-devel >= 0.9.7
    20. libpoppler-cpp-devel
    21. libpoppler-devel
    22. libqxp-devel
    23. libssl-devel
    24. libtiff-devel >= 3.6.0
    25. libvisio-devel
    26. libwmf-devel
    27. libxml2-devel >= 2.6.0
    28. libzmf-devel
    29. rpm-macros-cmake
    30. python3-dev
    31. python3-module-Pillow
    32. zlib-devel
    33. qt5-base-devel >= 5.5.0
    34. qt5-declarative-devel
    35. qt5-imageformats
    36. qt5-tools-devel
    37. rpm-build-python3

Last changed


Dec. 20, 2023 Grigory Ustinov 1:1.5.8-alt3
- fix building with python3.12.
April 25, 2023 Michael Shigorin 1:1.5.8-alt2
- fix build against poppler 22.09 with debian patches (ALT#44772)
- spec cleanup
April 9, 2022 Vitaly Lipatov 1:1.5.8-alt1
- new version 1.5.8 (with rpmrb script)
- fix build with poppler 22.02 and poppler 22.03
- enable C++ 17 build (new popper wants it)