Package systemd: Information

    Source package: systemd
    Version: 255.6-alt2
    Latest version according to Repology
    Build time:  May 26, 2024, 02:10 AM in the task #349296
    Report package bug
    License: LGPLv2.1+
    Summary: System and Session Manager
    Description: 
    systemd is a system and session manager for Linux, compatible with
    SysV and LSB init scripts. systemd provides aggressive parallelization
    capabilities, uses socket and D-Bus activation for starting services,
    offers on-demand starting of daemons, keeps track of processes using
    Linux cgroups, supports snapshotting and restoring of the system
    state, maintains mount and automount points and implements an
    elaborate transactional dependency-based service control logic. It can
    work as a drop-in replacement for sysvinit.

    List of rpms provided by this srpm:
    libnss-myhostname (x86_64, ppc64le, i586, aarch64)
    libnss-myhostname-debuginfo (x86_64, ppc64le, i586, aarch64)
    libnss-mymachines (x86_64, ppc64le, i586, aarch64)
    libnss-mymachines-debuginfo (x86_64, ppc64le, i586, aarch64)
    libnss-resolve (x86_64, ppc64le, i586, aarch64)
    libnss-resolve-debuginfo (x86_64, ppc64le, i586, aarch64)
    libnss-systemd (x86_64, ppc64le, i586, aarch64)
    libnss-systemd-debuginfo (x86_64, ppc64le, i586, aarch64)
    libsystemd (x86_64, ppc64le, i586, aarch64)
    libsystemd-debuginfo (x86_64, ppc64le, i586, aarch64)
    libsystemd-devel (x86_64, ppc64le, i586, aarch64)
    libudev-devel (x86_64, ppc64le, i586, aarch64)
    libudev1 (x86_64, ppc64le, i586, aarch64)
    libudev1-debuginfo (x86_64, ppc64le, i586, aarch64)
    pam_systemd (x86_64, ppc64le, i586, aarch64)
    pam_systemd-debuginfo (x86_64, ppc64le, i586, aarch64)
    pam_systemd_home (x86_64, ppc64le, i586, aarch64)
    pam_systemd_home-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd (x86_64, ppc64le, i586, aarch64)
    systemd-analyze (x86_64, ppc64le, i586, aarch64)
    systemd-analyze-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-boot-efi (x86_64, i586, aarch64)
    systemd-boot-efi-debuginfo (x86_64, i586, aarch64)
    systemd-container (x86_64, ppc64le, i586, aarch64)
    systemd-container-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-coredump (x86_64, ppc64le, i586, aarch64)
    systemd-coredump-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-homed (x86_64, ppc64le, i586, aarch64)
    systemd-homed-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-journal-remote (x86_64, ppc64le, i586, aarch64)
    systemd-journal-remote-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-modules-common (noarch)
    systemd-networkd (x86_64, ppc64le, i586, aarch64)
    systemd-networkd-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-oomd-defaults (noarch)
    systemd-portable (x86_64, ppc64le, i586, aarch64)
    systemd-portable-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-stateless (noarch)
    systemd-sysctl-common (x86_64, ppc64le, i586, aarch64)
    systemd-sysvinit (noarch)
    systemd-tests (x86_64, ppc64le, i586, aarch64)
    systemd-tests-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-timesyncd (x86_64, ppc64le, i586, aarch64)
    systemd-timesyncd-debuginfo (x86_64, ppc64le, i586, aarch64)
    systemd-tmpfiles-common (noarch)
    systemd-ukify (x86_64, i586, aarch64)
    systemd-utils-filetriggers (noarch)
    systemd-utils-standalone (x86_64, ppc64le, i586, aarch64)
    systemd-utils-standalone-debuginfo (x86_64, ppc64le, i586, aarch64)
    udev (x86_64, ppc64le, i586, aarch64)
    udev-debuginfo (x86_64, ppc64le, i586, aarch64)

    Maintainer: Arseny Maslennikov



      1. acl
      2. bzlib-devel
      3. diffutils
      4. docbook-dtds
      5. docbook-style-xsl
      6. elfutils-devel >= 0.158
      7. glibc-kernheaders
      8. gperf
      9. intltool >= 0.40.0
      10. kexec-tools
      11. kmod
      12. libacl-devel
      13. libaudit-devel
      14. libcap-devel
      15. libcap-utils
      16. libcryptsetup-devel >= 2.0.1
      17. libdbus-devel >= 1.11.0
      18. libdw-devel
      19. libgcrypt-devel >= 1.4.5
      20. libgpg-error-devel >= 1.12
      21. libkeyutils-devel
      22. libkmod-devel >= 15
      23. liblz4-devel
      24. liblzma-devel
      25. libmount-devel >= 2.30
      26. libpam-devel
      27. libssl-devel >= 1.1.0
      28. python3(PIL)
      29. libtpm2-tss-devel
      30. python3(pefile)
      31. quota
      32. python3(jinja2)
      33. rpm-build-python3
      34. rpm-build-xdg
      35. rpm-macros-systemd >= 5
      36. meson >= 0.60.0
      37. python3(zstd)
      38. python3-module-elftools
      39. python3-module-lxml
      40. pkgconfig(blkid) >= 2.24
      41. pkgconfig(fdisk) >= 2.32
      42. pkgconfig(gnutls) >= 3.1.4
      43. pkgconfig(libcurl) >= 7.32.0
      44. pkgconfig(libfido2)
      45. pkgconfig(libidn2) >= 2.0.0
      46. pkgconfig(libiptc)
      47. pkgconfig(liblz4) >= 1.3.0
      48. pkgconfig(liblzma)
      49. pkgconfig(libmicrohttpd) >= 0.9.33
      50. pkgconfig(libpcre2-8)
      51. pkgconfig(libseccomp) >= 2.3.1
      52. pkgconfig(libselinux) >= 2.1.9
      53. pkgconfig(libzstd) >= 1.4.0
      54. pkgconfig(mount) >= 2.27
      55. pkgconfig(openssl) >= 1.1.0
      56. pkgconfig(p11-kit-1) >= 0.23.3
      57. pkgconfig(passwdqc)
      58. pkgconfig(polkit-gobject-1)
      59. pkgconfig(xkbcommon) >= 0.3.0
      60. pkgconfig(zlib)
      61. xsltproc

    Last changed


    May 25, 2024 Arseny Maslennikov 1:255.6-alt2
    - Fix compatibility with packages which install files outside %_prefix, IOW,
      in the legacy unmerged-usr locations. (thanks to sin@)
    May 13, 2024 Alexey Shabalin 1:255.6-alt1
    - 255.6
    - Migrate from /lib to /usr/lib (usrmerge).
    - Build with p11kit and fido2 support.
    April 18, 2024 Arseny Maslennikov 1:254.10-alt2
    - Adapted the package for filesystem >= 3:
      + put /bin after /usr/bin in default PATH for spawned processes;
      + fix symlink targets which were relative for standalone legacy directories.
      This makes us incompatible with filesystem < 3.
      See https://altlinux.org/Usrmerge for more information.