Package samba

Source package: samba
Version: 4.14.13-alt1
Build time:  May 13, 2022, 01:51 PM
Category: System/Servers
Report package bug
License:  GPLv3+ and LGPLv3+
Summary:  The Samba4 CIFS and AD client and server suite
Description: 
Samba is the standard Windows interoperability suite of programs for Linux and Unix.
List of rpms provided by this srpm: 
admx-samba (noarch)
libldb-modules-dc (e2kv6, e2kv5, e2kv4, e2k)
libldb-modules-dc-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
libsmbclient (e2kv6, e2kv5, e2kv4, e2k)
libsmbclient-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
libsmbclient-devel (e2kv6, e2kv5, e2kv4, e2k)
libwbclient (e2kv6, e2kv5, e2kv4, e2k)
libwbclient-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
libwbclient-devel (e2kv6, e2kv5, e2kv4, e2k)
python3-module-samba (e2kv6, e2kv5, e2kv4, e2k)
python3-module-samba-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
python3-module-samba-devel (e2kv6, e2kv5, e2kv4, e2k)
samba (e2kv6, e2kv5, e2kv4, e2k)
samba-client (e2kv6, e2kv5, e2kv4, e2k)
samba-client-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-common (noarch)
samba-common-client (noarch)
samba-common-libs (e2kv6, e2kv5, e2kv4, e2k)
samba-common-libs-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-common-tools (e2kv6, e2kv5, e2kv4, e2k)
samba-common-tools-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-dc (e2kv6, e2kv5, e2kv4, e2k)
samba-dc-client (e2kv6, e2kv5, e2kv4, e2k)
samba-dc-common (noarch)
samba-dc-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-dc-libs (e2kv6, e2kv5, e2kv4, e2k)
samba-dc-libs-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-dc-mitkrb5 (e2kv6, e2kv5, e2kv4, e2k)
samba-dc-mitkrb5-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-devel (e2kv6, e2kv5, e2kv4, e2k)
samba-doc (noarch)
samba-libs (e2kv6, e2kv5, e2kv4, e2k)
samba-libs-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-pidl (noarch)
samba-test (e2kv6, e2kv5, e2kv4, e2k)
samba-test-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-util-private-headers (e2kv6, e2kv5, e2kv4, e2k)
samba-vfs-snapper (e2kv6, e2kv5, e2kv4, e2k)
samba-vfs-snapper-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-clients (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-clients-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-common (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-krb5-localauth (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-krb5-localauth-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-krb5-locator (e2kv6, e2kv5, e2kv4, e2k)
samba-winbind-krb5-locator-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
task-samba-dc (noarch)
task-samba-dc-mitkrb5 (noarch)
Last changes:
April 5, 2022 Evgeny Sinelnikov 4.14.13-alt1
- Update to latest bugfix release of Samba 4.14
- Fixes:
  + Renaming file on DFS root fails with NT_STATUS_OBJECT_PATH_NOT_FOUND.
  + Samba does not response STATUS_INVALID_PARAMETER when opening 2 objects with
    same lease key.
  + NT error code is not set when overwriting a file during rename in libsmbclient.
  + net ads info shows LDAP Server: 0.0.0.0 depending on contacted server.
  + wbinfo -a doesn't work reliable with upn names.
  + Problem when winbind renews Kerberos.
  + NT_STATUS_ACCESS_DENIED translates into EPERM instead of EACCES in
    SMBC_server_internal.
  + Multpile RODC fixes:
    - Simple bind doesn't work against an RODC (with non-preloaded users).
    - Crash of winbind on RODC.
    - Uncached logon on RODC always fails once.
    - Changing the machine password against an RODC likely destroys the domain join.
    - Simple bind doesn't work against an RODC (with non-preloaded users).
  + Avoid mixing the main krbtgt account keys with an RODC if the
    msDS-KeyVersionNumber is larger than 65535 (set 16 upper bits to zero).
  + Use Heimdal 8.0 (pre) rather than an earlier snapshot.
  + LDAP simple binds should honour "old password allowed period".
  + Fix ldap simple bind with TLS auditing.
  + "password hash userPassword schemes = CryptSHA256" does not seem to work
    with samba-tool.
March 3, 2022 Evgeny Sinelnikov 4.14.12-alt2
- Fix linking of some libraries (libsmbldap.so.2.1.0, libpopt-samba3-samba4.so,
  libsamba-modules-samba4.so, winbind_krb5_locator.so and smbpasswd.so):
  + find-requires: ERROR: /usr/lib/rpm/lib.req failed.
Feb. 9, 2022 Evgeny Sinelnikov 4.14.12-alt1
- Update to latest security release of Samba 4.14
- Security fixes:
  + CVE-2021-44142: Out-of-Bound Read/Write on Samba vfs_fruit module.
  + CVE-2022-0336:  Re-adding an SPN skips subsequent SPN conflict checks.

Back to Top