Package gem-webmock: Information

    Source package: gem-webmock
    Version: 3.14.0-alt1
    Build time:  Aug 16, 2023, 08:10 AM
    Category: Development/Ruby
    Report package bug
    License: MIT
    Summary: Library for stubbing and setting expectations on HTTP requests in Ruby
    Description: 
    Library for stubbing and setting expectations on HTTP requests in Ruby.
    
    * Stubbing HTTP requests at low http client lib level (no need to change tests
    when you change HTTP library)
    * Setting and verifying expectations on HTTP requests
    * Matching requests based on method, URI, headers and body
    * Smart matching of the same URIs in different representations (also encoded and
    non encoded forms)
    * Smart matching of the same headers in different representations.
    * Support for Test::Unit
    * Support for RSpec
    * Support for MiniTest

    List of rpms provided by this srpm:
    gem-webmock (noarch)
    gem-webmock-devel (noarch)
    gem-webmock-doc (noarch)


    List of contributors:
    Pavel Skrylev

      1. gem(patron) >= 0.4.18
      2. gem(rack) > 1.6
      3. gem(rdoc) > 3.5.0
      4. gem(rspec) >= 3.1.0
      5. gem(test-unit) >= 3.0.0
      6. gem(typhoeus) >= 0.5.0
      7. gem(webrick) >= 1.7.0
      8. rpm-build-ruby
      9. gem(addressable) >= 2.8.0
      10. gem(async-http) >= 0.48.0
      11. gem(minitest) >= 5.0.0
      12. gem(hashdiff) >= 0.4.0
      13. gem(hashdiff) < 2.0.0
      14. gem(crack) >= 0.3.2
      15. gem(curb) >= 0.7.16
      16. gem(httpclient) >= 2.2.4
      17. gem(em-http-request) >= 1.0.2
      18. gem(em-synchrony) >= 1.0.0
      19. gem(excon) >= 0.27.5

    Last changed


    April 19, 2022 Pavel Skrylev 3.14.0-alt1
    - ^ 3.13.0 -> 3.14.0
    July 1, 2021 Pavel Skrylev 3.13.0-alt1
    - ^ 3.7.5 -> 3.13.0
    Sept. 24, 2019 Pavel Skrylev 3.7.5-alt1
    - ^ 3.6.0 -> 3.7.5
    - ! spec