Package grpc: Information

Source package: grpc
Version: 1.38.0-alt1.2
Build time:  Jun 13, 2023, 01:12 PM
Category: Networking/Other
Report package bug
License: Apache-2.0
Summary: Modern, open source, high-performance remote procedure call (RPC) framework
Description: 
gRPC is a modern open source high performance RPC framework that can run in any
environment. It can efficiently connect services in and across data centers with
pluggable support for load balancing, tracing, health checking and
authentication. It is also applicable in last mile of distributed computing to
connect devices, mobile applications and browsers to backend services.

The main usage scenarios:

* Efficiently connecting polyglot services in microservices style architecture
* Connecting mobile devices, browser clients to backend services
* Generating efficient client libraries

Core Features that make it awesome:

* Idiomatic client libraries in 10 languages
* Highly efficient on wire and with a simple service definition framework
* Bi-directional streaming with http/2 based transport
* Pluggable auth, tracing, load balancing and health checking

List of rpms provided by this srpm:
gem-grpc (mipsel)
gem-grpc-debuginfo (mipsel)
gem-grpc-doc (noarch)
gem-grpc-tools (noarch)
grpc-plugins (mipsel)
grpc-plugins-debuginfo (mipsel)
grpc-tools-ruby-protoc (noarch)
libgrpc (mipsel)
libgrpc++ (mipsel)
libgrpc++-debuginfo (mipsel)
libgrpc++-devel (mipsel)
libgrpc-debuginfo (mipsel)
libgrpc-devel (mipsel)

Maintainer: Pavel Skrylev


    1. pkgconfig(zlib)
    2. cmake
    3. rpm-build-ruby
    4. rpm-macros-cmake
    5. protobuf-compiler
    6. libprotobuf-devel
    7. gcc-c++
    8. libcares-devel
    9. libre2-devel
    10. openssl-devel
    11. libabseil-cpp-devel

Last changed


July 24, 2021 Pavel Skrylev 1.38.0-alt1.2
- ! closes gem build requires with check condition
July 24, 2021 Pavel Skrylev 1.38.0-alt1.1
- + ruby packages
June 1, 2021 Pavel Skrylev 1.38.0-alt1
- ^ 1.35.0 -> 1.38.0