Package ruby: Information

    Source package: ruby
    Version: 3.1.4-alt4.3
    Build time:  Apr 16, 2024, 07:41 AM
    Category: Development/Ruby
    Report package bug
    License: BSD-2-Clause or Ruby
    Summary: An Interpreted Object-Oriented Scripting Language
    Description: 
    Ruby is an interpreted scripting language for quick and easy object-oriented
    programming. It has many features for processing text files and performing
    system management tasks (as in Perl). It is simple, straight-forward, and
    extensible.
    
    This package contains interpreter of object-oriented scripting language Ruby.

    List of rpms provided by this srpm:
    erb (noarch)
    gem (noarch)
    irb (noarch)
    libruby (riscv64)
    libruby-debuginfo (riscv64)
    libruby-devel (riscv64)
    rpm-macros-ruby (riscv64)
    ruby (riscv64)
    ruby-debuginfo (riscv64)
    ruby-devel (noarch)
    ruby-doc (noarch)
    ruby-doc-html (riscv64)
    ruby-stdlibs (riscv64)
    ruby-stdlibs-debuginfo (riscv64)

    Maintainer: Michael Shigorin


      1. /proc
      2. autoconf >= 2.71
      3. rpm-macros-valgrind
      4. rvm-devel

    Last changed


    April 15, 2024 Michael Shigorin 3.1.4-alt4.3
    - get P: rubygems back
    April 15, 2024 Michael Shigorin 3.1.4-alt4.2
    - E2K: add platform patch (ilyakurdyukov@)
    - add BR: /proc to fix build on %e2k
    - gem subpackage (inter)dep fixup
    - minor spec cleanup (see also ALT#46206)
    March 25, 2024 Pavel Skrylev 3.1.4-alt4.1
    - * changed names for doc packages: ri is doc, html is doc-html (closes #36294)