Package strongswan

Source package: strongswan
Version: 4.6.4-alt1.M60T.1
Build time:  Apr 30, 2013, 04:30 PM
Category: System/Servers
Report package bug
License:  GPLv2+
Summary:  StrongSWAN IPSEC implementation
Description: 
StrongSWAN is a free implementation of IPSEC & IKE for Linux.  IPSEC is
the Internet Protocol Security and uses strong cryptography to provide
both authentication and encryption services.  These services allow you
to build secure tunnels through untrusted networks.  Everything passing
through the untrusted net is encrypted by the ipsec gateway machine and
decrypted by the gateway at the other end of the tunnel.  The resulting
tunnel is a virtual private network or VPN.

This package contains the service and userland tools for setting up
StrongSWAN on a freeswan enabled kernel.
List of rpms provided by this srpm: 
strongswan (x86_64, i586)
strongswan-debuginfo (x86_64, i586)
strongswan-testing (noarch)
Last changes:
April 30, 2013 Michael Shigorin 4.6.4-alt1.M60T.1
- applied the upstream provided patch to fix CVE-2013-2944
  (ECDSA signature vulnerability if openssl backend is loaded)
June 1, 2012 Michael Shigorin 4.6.4-alt1
- 4.6.4
  + CVE-2012-2388 is fixed (an attacker presenting a forged
    signature and/or certificate can authenticate as any
    legitimate user provided that "gmp" plugin is in use
    and a connection definition using RSA auth exists)
May 3, 2012 Michael Shigorin 4.6.3-alt1
- 4.6.3
  + patch2 unneeded (included upstream)

Back to Top