Vulnerability CVE-2020-15953: Information

Description

LibEtPan through 1.9.4, as used in MailCore 2 through 0.6.3 and other products, has a STARTTLS buffering issue that affects IMAP, SMTP, and POP3. When a server sends a "begin TLS" response, the client reads additional data (e.g., from a meddler-in-the-middle attacker) and evaluates it in a TLS context, aka "response injection."

Severity: HIGH (7.4) Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Published: July 27, 2020
Modified: Nov. 7, 2023
Error type identifier: CWE-74

Fixed packages

Package name
Branch
Fixed in version
Version from repository
Errata ID
Task #
State
libetpansisyphus1.9.4-alt21.9.4-alt4ALT-PU-2020-2908-1259052Fixed
libetpansisyphus_e2k1.9.4-alt41.9.4-alt4ALT-PU-2023-7033-1-Fixed
libetpansisyphus_mipsel1.9.4-alt41.9.4-alt4ALT-PU-2023-7068-1-Fixed
libetpansisyphus_riscv641.9.4-alt41.9.4-alt4ALT-PU-2023-7113-1-Fixed
libetpanp101.9.4-alt41.9.4-alt4ALT-PU-2023-7017-2333836Fixed
libetpanp10_e2k1.9.4-alt41.9.4-alt4ALT-PU-2023-7456-1-Fixed
libetpanp91.9.4-alt21.9.4-alt4ALT-PU-2020-2942-1259053Fixed
libetpanp9_e2k1.9.4-alt41.9.4-alt4ALT-PU-2023-7707-1-Fixed
libetpanp9_mipsel1.9.4-alt41.9.4-alt4ALT-PU-2023-7293-1-Fixed
libetpanc10f11.9.4-alt41.9.4-alt4ALT-PU-2023-7434-2334780Fixed
libetpanc9f21.9.4-alt41.9.4-alt4ALT-PU-2023-7051-3333922Fixed

References to Advisories, Solutions, and Tools

    1. Configuration 1

      cpe:2.3:a:libetpan_project:libetpan:*:*:*:*:*:*:*:*

      Configuration 2

      cpe:2.3:a:libmailcore:mailcore2:*:*:*:*:*:*:*:*

      Configuration 3

      cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*

      cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*

      Configuration 4

      cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*