Vulnerability CVE-2021-4009: Information

Description

A flaw was found in xorg-x11-server in versions before 21.1.2 and before 1.20.14. An out-of-bounds access can occur in the SProcXFixesCreatePointerBarrier function. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Severity: HIGH (7.8) Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Published: Dec. 17, 2021
Modified: Nov. 7, 2023
Error type identifier: CWE-119

Fixed packages

Package name
Branch
Fixed in version
Version from repository
Errata ID
Task #
State
xorg-serversisyphus1.20.13-alt521.1.11-alt1ALT-PU-2021-3534-1291952Fixed
xorg-serversisyphus_e2k1.20.14-alt8.E2K.121.1.3-alt1.E2K.1ALT-PU-2023-3913-1-Fixed
xorg-serversisyphus_riscv641.20.14-alt121.1.11-alt1ALT-PU-2021-4696-1-Fixed
xorg-serverp101.20.13-alt51.20.14-alt11ALT-PU-2021-3623-1291987Fixed
xorg-serverp10_e2k1.20.14-alt8.E2K.21.20.14-alt9.E2K.1ALT-PU-2023-6819-1-Fixed
xorg-serverp91.20.8-alt101.20.8-alt12ALT-PU-2023-7278-2334512Fixed
xorg-serverc10f11.20.13-alt51.20.14-alt9ALT-PU-2021-3623-1291987Fixed
xorg-serverc9f21.20.8-alt121.20.8-alt9ALT-PU-2024-3261-1341756Testing

References to Advisories, Solutions, and Tools

    1. Configuration 1

      cpe:2.3:a:x.org:x_server:*:*:*:*:*:*:*:*
      End excliding
      1.20.14

      cpe:2.3:a:x.org:x_server:21.1.1:*:*:*:*:*:*:*

      cpe:2.3:a:x.org:x_server:21.1.0:*:*:*:*:*:*:*

      Configuration 2

      cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*

      cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*

      Configuration 3

      cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*

      cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

      cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*