Vulnerability CVE-2024-35241: Information

Description

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `status`, `reinstall` and `remove` commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code. Patches for this issue are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid installing dependencies via git by using `--prefer-dist` or the `preferred-install: dist` config setting.

Published: June 11, 2024
Modified: June 20, 2024

Fixed packages

Package name
Branch
Fixed in version
Version from repository
Errata ID
Task #
State
composersisyphus2.7.7-alt12.7.7-alt1ALT-PU-2024-9688-2352349Fixed
composersisyphus_loongarch642.7.7-alt12.7.7-alt1ALT-PU-2024-9701-1-Fixed

References to Advisories, Solutions, and Tools