Vulnerability CVE-2024-35242: Information

Description

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch names can lead to command injection. This requires cloning untrusted repositories. Patches are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid cloning potentially compromised repositories.

Published: June 11, 2024
Modified: June 20, 2024

Fixed packages

Package name
Branch
Fixed in version
Version from repository
Errata ID
Task #
State
composersisyphus2.7.7-alt12.7.7-alt1ALT-PU-2024-9688-2352349Fixed
composersisyphus_loongarch642.7.7-alt12.7.7-alt1ALT-PU-2024-9701-1-Fixed

References to Advisories, Solutions, and Tools