Vulnerability CVE-2024-4577: Information

Description

In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, when using Apache and PHP-CGI on Windows, if the system is set up to use certain code pages, Windows may use "Best-Fit" behavior to replace characters in command line given to Win32 API functions. PHP CGI module may misinterpret those characters as PHP options, which may allow a malicious user to pass options to PHP binary being run, and thus reveal the source code of scripts, run arbitrary PHP code on the server, etc.

Severity: CRITICAL (9.8) Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Published: June 9, 2024
Modified: June 13, 2024
Error type identifier: CWE-78

Fixed packages

Package name
Branch
Fixed in version
Version from repository
Errata ID
Task #
State
php8.1sisyphus8.1.29-alt18.1.29-alt1ALT-PU-2024-8847-1350654Fixed
php8.1sisyphus_e2k8.1.29-alt18.1.29-alt1ALT-PU-2024-9120-1-Fixed
php8.1sisyphus_riscv648.1.29-alt18.1.29-alt1ALT-PU-2024-8970-1-Fixed
php8.1sisyphus_loongarch648.1.29-alt18.1.29-alt1ALT-PU-2024-8981-1-Fixed
php8.1p118.1.29-alt18.1.29-alt1ALT-PU-2024-8853-2350658Fixed
php8.2sisyphus8.2.20-alt18.2.20-alt1ALT-PU-2024-8849-1350656Fixed
php8.2sisyphus_e2k8.2.20-alt18.2.20-alt1ALT-PU-2024-9107-1-Fixed
php8.2sisyphus_riscv648.2.20-alt18.2.20-alt1ALT-PU-2024-9007-1-Fixed
php8.2sisyphus_loongarch648.2.20-alt18.2.20-alt1ALT-PU-2024-8982-1-Fixed
php8.2p10_e2k8.2.20-alt18.2.20-alt1ALT-PU-2024-9115-1-Fixed
php8.2p118.2.20-alt18.2.20-alt1ALT-PU-2024-8859-2350659Fixed
php8.3sisyphus8.3.8-alt18.3.8-alt1ALT-PU-2024-8855-1350657Fixed
php8.3sisyphus_e2k8.3.8-alt18.3.8-alt1ALT-PU-2024-9109-1-Fixed
php8.3sisyphus_riscv648.3.8-alt18.3.8-alt1ALT-PU-2024-8972-1-Fixed
php8.3sisyphus_loongarch648.3.8-alt18.3.8-alt1ALT-PU-2024-8983-1-Fixed
php8.3p118.3.8-alt18.3.8-alt1ALT-PU-2024-8861-2350660Fixed

References to Advisories, Solutions, and Tools

Hyperlink
Resource
https://github.com/php/php-src/security/advisories/GHSA-3qgc-jrrr-25jv
  • Broken Link
https://blog.orange.tw/2024/06/cve-2024-4577-yet-another-php-rce.html
  • Third Party Advisory
https://devco.re/blog/2024/06/06/security-alert-cve-2024-4577-php-cgi-argument-injection-vulnerability-en/
  • Exploit
  • Third Party Advisory
https://arstechnica.com/security/2024/06/php-vulnerability-allows-attackers-to-run-malicious-code-on-windows-servers/
  • Exploit
  • Third Party Advisory
https://www.imperva.com/blog/imperva-protects-against-critical-php-vulnerability-cve-2024-4577/
  • Third Party Advisory
https://github.com/11whoami99/CVE-2024-4577
  • Exploit
https://github.com/xcanwin/CVE-2024-4577-PHP-RCE
  • Exploit
  • Third Party Advisory
https://github.com/rapid7/metasploit-framework/pull/19247
  • Exploit
https://labs.watchtowr.com/no-way-php-strikes-again-cve-2024-4577/
  • Exploit
  • Third Party Advisory
https://github.com/watchtowrlabs/CVE-2024-4577
  • Exploit
  • Third Party Advisory
https://www.php.net/ChangeLog-8.php#8.1.29
  • Release Notes
https://www.php.net/ChangeLog-8.php#8.2.20
  • Release Notes
https://www.php.net/ChangeLog-8.php#8.3.8
  • Release Notes
https://cert.be/en/advisory/warning-php-remote-code-execution-patch-immediately
  • Third Party Advisory
https://isc.sans.edu/diary/30994
  • Exploit
  • Third Party Advisory
http://www.openwall.com/lists/oss-security/2024/06/07/1
    https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PKGTQUOA2NTZ3RXN22CSAUJPIRUYRB4B/
      https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W45DBOH56NQDRTOM2DN2LNA2FZIMC3PK/
          1. Configuration 1

            cpe:2.3:a:php:php:*:*:*:*:*:*:*:*
            Start including
            5.0.0
            End excliding
            8.1.29

            cpe:2.3:a:php:php:*:*:*:*:*:*:*:*
            Start including
            8.2.0
            End excliding
            8.2.20

            cpe:2.3:a:php:php:*:*:*:*:*:*:*:*
            Start including
            8.3.0
            End excliding
            8.3.8