Категория Разработка/Ruby

ruby 18 ноября 2020 г. 16:5418 ноября 2020 г. 16:54
Версия: 2.5.9-alt1
О пакете: An Interpreted Object-Oriented Scripting Language
Изменения:
- ^ 2.5.5 -> 2.5.9
- Fixes:
  + CVE-2019-16255: A code injection vulnerability of Shell#[] and Shell#test
    (closes #39292)
  + CVE-2019-16254: HTTP response splitting in WEBrick (Additional fix)
  + CVE-2019-15845: A NUL injection vulnerability of File.fnmatch and
    File.fnmatch?
  + CVE-2019-16201: Regular Expression Denial of Service vulnerability of
    WEBrick's Digest access authentication
gem-puppet 16 ноября 2020 г. 11:5416 ноября 2020 г. 11:54
Версия: 7.0.0-alt1
О пакете: A network tool for managing many disparate systems
Изменения:
- New version.
gem-smart-proxy 23 июля 2020 г. 22:1323 июля 2020 г. 22:13
Версия: 2.1.0-alt2
О пакете: RESTful proxies for DNS, DHCP, TFTP, BMC and Puppet
Изменения:
- + conf file to keep rights on some folders after reset
- + _smartforeman user with home of /var/lib/smart-proxy
- * moving config files to sysconf folder
- ! config dependent code
- ! config syntax
gem-setup 13 июля 2020 г. 19:0113 июля 2020 г. 19:01
Версия: 5.999.4-alt3
О пакете: Ruby's Classic Site Installer
Изменения:
- ! gemfile dep export in one line when dep name is the same
- ! spec syntax
azure-sdk-for-ruby 9 июля 2020 г. 12:319 июля 2020 г. 12:31
Версия: 20200316-alt1.2.0.mips1
О пакете: Ruby SDK for Azure Resource Manager
Изменения:
- reduce memory usage to fix build on mipsel
ruby-mustermann 15 июня 2020 г. 15:1515 июня 2020 г. 15:15
Версия: 1.1.1-alt1
О пакете: The Amazing Mustermann
Изменения:
- + packaged gem with usage Ruby Policy 2.0
gem-rsec 15 июня 2020 г. 14:2315 июня 2020 г. 14:23
Версия: 0.4.3-alt1
О пакете: Parser / Regexp Combinator For Ruby
Изменения:
- + packaged gem with usage Ruby Policy 2.0
gem-rubyipmi 15 июня 2020 г. 14:1615 июня 2020 г. 14:16
Версия: 0.10.0-alt1
О пакете: Command line wrapper for ipmitool and freeipmi
Изменения:
- + packaged gem with usage Ruby Policy 2.0
gem-hansi 15 июня 2020 г. 13:2115 июня 2020 г. 13:21
Версия: 0.2.0-alt1
О пакете: Der ANSI Hansi - create colorized console output
Изменения:
- + packaged gem with usage Ruby Policy 2.0
gem-ruby2-keywords 15 июня 2020 г. 12:1715 июня 2020 г. 12:17
Версия: 0.0.2-alt1
О пакете: Shim library for Module#ruby2_keywords
Изменения:
- + packaged gem with usage Ruby Policy 2.0
gem-rkerberos 15 июня 2020 г. 11:3315 июня 2020 г. 11:33
Версия: 0.1.5-alt1
О пакете: A Ruby interface for Kerberos
Изменения:
- + packaged gem with usage Ruby Policy 2.0
gem-dhcpsapi 11 июня 2020 г. 23:3611 июня 2020 г. 23:36
Версия: 0.0.11-alt1
О пакете: Ruby wrappers for MS DHCP api
Изменения:
- + packaged gem with usage Ruby Policy 2.0
gem-rabl 9 июня 2020 г. 19:419 июня 2020 г. 19:41
Версия: 0.14.3.1-alt1
О пакете: General ruby templating with json, bson, xml, plist and msgpack support
Изменения:
- ^ 0.14.2 -> 0.14.3+
- ! fault to require to active_view explicitly in code by patch
gem-concurrent-ruby 6 июня 2020 г. 18:206 июня 2020 г. 18:20
Версия: 1.1.6-alt1.1
О пакете: Modern concurrency tools including agents, futures, promises, thread pools, supervisors, and more.
Изменения:
- + java part
gem-sassc 6 июня 2020 г. 12:486 июня 2020 г. 12:48
Версия: 2.2.1-alt2.1
О пакете: Use libsass with Ruby!
Изменения:
- ! spec tags and syntax, build procedure
gem-coveralls 5 июня 2020 г. 19:195 июня 2020 г. 19:19
Версия: 0.8.23-alt1.1
О пакете: Coveralls for Ruby
Изменения:
- - spec dep to pry
gem-bump 4 июня 2020 г. 23:154 июня 2020 г. 23:15
Версия: 0.8.0-alt3.1
О пакете: Bump is a gem that will simplify the way you build gems
Изменения:
- + conflict dep to bumper
gem-rdiscount 4 июня 2020 г. 23:104 июня 2020 г. 23:10
Версия: 2.2.0.1-alt4.6
О пакете: Discount (For Ruby) Implementation of John Gruber's Markdown
Изменения:
- + conflict dep to libbobpp-devel, libdiscount-devel, libpicosat-devel
gem-rexical 27 мая 2020 г. 10:3427 мая 2020 г. 10:34
Версия: 1.0.7-alt1.3
О пакете: Lexical scanner generator for ruby
Изменения:
- ! spec and syntax
- * relicensed
gem-ruby-parser 26 мая 2020 г. 22:4126 мая 2020 г. 22:41
Версия: 3.14.2-alt0.1
О пакете: ruby_parser (RP) is a ruby parser written in pure ruby
Изменения:
- updated (^) 3.13.1 -> 3.14.2
- fixed (!) spec
Наверх