Пакет apt-repo-tools

Исходный пакет: apt-repo-tools
Версия: 0.8.0-alt1
Собран:  10 февраля 2022 г. 4:01
Категория: Разработка/Прочее
Сообщить об ошибке в пакете
Домашняя страница: 
Лицензия:  GPLv2+
О пакете:  Utilities to create APT repositories
Описание: 
This package contains the utility programs that can prepare a repository
of RPMS binary and source packages for future access by APT (by
generating the indices): genbasedir, genpkglist, gensrclist.
Список rpm-пакетов, предоставляемых данным srpm-пакетом: 
apt-repo-tools (e2kv6, e2kv5, e2kv4, e2k)
apt-repo-tools-debuginfo (e2kv6, e2kv5, e2kv4, e2k)
    1. libapt-devel
    2. gcc-c++
    3. librpm-devel
Последние изменения:
28 октября 2021 г. Gleb Fotengauer-Malinovskiy 0.8.0-alt1
- Switched to librpm crypto API instead of libapt.
- Added support and enabled blake2b hash by default.
- genbasedir: add --disable-hash-caching option to disable hashsum caching.
12 марта 2021 г. Gleb Fotengauer-Malinovskiy 0.7.1-alt1
- genbasedir/genpkglist: fixed generation of non-flat repositories.
- genbasedir (imz@):
  + Fixed SIGPIPE in the old non-patching mode. (It was due to a race.)
  + Fixed patching srclist in-place when there is no uncompressed srclist.
  + Fixed patching a basedir if there is a spurious {pkg,src}list.*.old file
    there, but no uncompressed {pkg,src}list.*.
  + Fixed a potential bug (due to a race) of choosing the overwritten
    output file as input for patching.
  + Report an error when patching and the previous list can't be found.
  + Do the search for the previous list the same way no matter whether
    --prev-basedir was specified or patching "in-place".
26 октября 2020 г. Gleb Fotengauer-Malinovskiy 0.7.0-alt1
- Added new options to patch package index.
- Added --basedir option to specify base directory name.
- genbasedir: added support for zstd-compressed package lists.
- genpkglist, gensrclist:
  + removed --append option;
  + removed --meta option.
- genpkglist: fixed --cachedir description in usage (ALT#38293).
- imz@:
  + (.spec) Just added some compiler flags (which don't change anything) to be
  sure that APT API has not been used wrongly and will not be.  (Namely, to be
  sure that if a method override was intended, it would actually be overriding
  and not hiding a virtual method and that it would be marked "override" for
  future.).

Наверх